Kitz ADSL Broadband Information
adsl spacer  
Support this site
Home Broadband ISPs Tech Routers Wiki Forum
 
     
   Compare ISP   Rate your ISP
   Glossary   Glossary
 
Please login or register.

Login with username, password and session length
Advanced search  

News:

Author Topic: Help with IE not opening certain websites  (Read 2939 times)

robber789

  • Just arrived
  • *
  • Posts: 7
Help with IE not opening certain websites
« on: May 09, 2011, 11:10:39 AM »

Hi guys - hope you can help with this.

Just recently, IE8 has started displaying 'Internet Explorer cannot display the webpage' messages, but only for certain websites - most open with no probs.

If i try the offending sites with Opera, I get 'Connection closed by remote server'

This is on my win7 pc, but I have the same problem on my wife's win7 pc - both on the same network/router.

however, if I go to my Vista pc (not sure which version of IE is running) on the same network, the offending sites open fine.

Any ideas?

All help apprecioated.

rob
Logged

tuftedduck

  • Senior Kitizen
  • ******
  • Posts: 29658
  • Router Luvvin Duck
Re: Help with IE not opening certain websites
« Reply #1 on: May 09, 2011, 02:30:18 PM »

 Hello, robber789 and welcome to the Forum  :)

It may be that there is a setting somewhere on your Win7 machines that is blocking these sites.
Have you checked in the firewall and/or antivirus prog settings to see if there is a blacklist against the sites in question ?
Also that your security settings in IE and Opera are not set too high, or that the sites are not listed in there as being blocked.
Logged

robber789

  • Just arrived
  • *
  • Posts: 7
Re: Help with IE not opening certain websites
« Reply #2 on: May 09, 2011, 04:43:07 PM »

Thanks.

Thing is, I'm not aware of changing any settings, and this problem has occurred only relatively recently.

My suspicion is that win7 has performed an automatic update (on both win7 machines) that is affecting my internet access.

I might try rolling one machine back with System Restore to see what happens....

rob
Logged

robber789

  • Just arrived
  • *
  • Posts: 7
Re: Help with IE not opening certain websites
« Reply #3 on: May 09, 2011, 05:40:47 PM »

Later....

Well, I don't think it's my firewall, because turning it off (briefly) doesn't help - I still can't open some sites.

And I can't really use system restore, as there are only a very few points available, and all apparently within the last week.

Ridiculous!

rob
Logged

UncleUB

  • Helpful
  • Senior Kitizen
  • *
  • Posts: 29542
Re: Help with IE not opening certain websites
« Reply #4 on: May 09, 2011, 06:00:04 PM »

Have you tried with Firefox or Chrome?

Which sites are you having problems with?
Logged

robber789

  • Just arrived
  • *
  • Posts: 7
Re: Help with IE not opening certain websites
« Reply #5 on: May 10, 2011, 09:14:56 AM »

Firefox shows the same behavious as IE and Opera - it reports 'Firefox can't establish a connection to the server at www.ashampoo.com.'

That's one of the many sites I have a problem with - another is fsa.gov.uk.

IE now says 'DNS error occurred. Server cannot be found'

As well as disabling my firewall, I briefly disabled antivirus as well - no difference.

I'm baffled!

rob
Logged

roseway

  • Administrator
  • Senior Kitizen
  • *
  • Posts: 40717
  • Penguins CAN fly
    • DSLstats
Re: Help with IE not opening certain websites
« Reply #6 on: May 10, 2011, 09:26:35 AM »

I think that gives you the answer - there's something wrong with the DNS service which you use. You can confirm this by opening a terminal and typing

  ping www.ashampoo.com

which will fail to return a result if the DNS lookup fails. If this is the case, then go into your router configuration and find the section where the DNS server is defined. Very probably, this says 'Get DNS server automatically' or words to that effect; change this to show fixed DNS servers, and try OpenDNS which has the addresses 208.67.222.222 and 208.67.220.220.
Logged
  Eric

robber789

  • Just arrived
  • *
  • Posts: 7
Re: Help with IE not opening certain websites
« Reply #7 on: May 10, 2011, 10:01:12 AM »

You're right - pinging a couple of the affected sites returns 'General failure'

So I altered the DNS settings in my router a Cisco (Linksys) WRT610N. This doesn't seem to have the facility to get the DNS server info automaticallly (or I couldn't find it...), so I entered the OpenDNS settings you gave.

Result - no change!

rob
Logged

roseway

  • Administrator
  • Senior Kitizen
  • *
  • Posts: 40717
  • Penguins CAN fly
    • DSLstats
Re: Help with IE not opening certain websites
« Reply #8 on: May 10, 2011, 11:21:12 AM »

In that case it's probably down to the DNS settings in your PCs. I see from your original message that your Vista PC works OK with the affected sites, but the two Win7 PCs don't. I don't use Windows myself, so can't advise on how to do this, but I think you need to compare the DNS settings in them and set up the Win7 PCs similarly to the Vista PC.
Logged
  Eric

jeffbb

  • Content Team
  • Kitizen
  • *
  • Posts: 2329
Re: Help with IE not opening certain websites
« Reply #9 on: May 10, 2011, 11:24:15 AM »

Logged
zen user

robber789

  • Just arrived
  • *
  • Posts: 7
Re: Help with IE not opening certain websites
« Reply #10 on: May 10, 2011, 12:54:58 PM »

Thanks Jeff - tried those links - same result...

Also tried  roseway's suggestion of replicating my Vista settings on my win7 machine - the only difference is that Vista was set to 'obtain DNS automatically'

I set my win7 machine to the same, but guess what - no change!

I have a drawerfull of routers lying around here, so my next step is to try a different router...

rob

Logged

robber789

  • Just arrived
  • *
  • Posts: 7
Re: Help with IE not opening certain websites
« Reply #11 on: May 10, 2011, 01:15:39 PM »

update - my wife's win7 machine now appears to be working fine - opens all the 'affected' sites.

Now I just have to try to identify how her config differs from mine....

rob
Logged