Kitz ADSL Broadband Information
adsl spacer  
Support this site
Home Broadband ISPs Tech Routers Wiki Forum
 
     
   Compare ISP   Rate your ISP
   Glossary   Glossary
 
Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: 1 ... 82 83 [84]

Author Topic: Modem/Router VDSL2 Technicolor DGA4130 (BCM63138)  (Read 404731 times)

nesousx

  • Just arrived
  • *
  • Posts: 2
Re: Modem/Router VDSL2 Technicolor DGA4130 (BCM63138)
« Reply #1245 on: November 22, 2021, 08:08:42 PM »

If it helps, this is how my HH5a are configured in the UK (have obfuscated the MAC addresses):
Code: [Select]
config interface 'loopback'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'
        option device 'lo'

config globals 'globals'
        option ula_prefix 'fd76:9236:9ad3::/48'

# Set the DSL parameters
config dsl 'dsl'
        option xfer_mode 'ptm'
        option line_mode 'vdsl'
        option ds_snr_offset '-35'
        option annex 'b'
        option tone 'a'

# Configure the LAN interface
config interface 'lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option gateway '192.168.1.254'
        list dns '192.168.1.254'
        option ipaddr '192.168.1.240'
        option stp '1'
        option device 'br-lan'

# Create VLAN1 interface on the SoC NIC for the LAN
config device 'lan_dev'
        option name 'eth0.1'
        option macaddr '18:1e:78:##:##:##'

# Create the Bridged WAN interface
config interface 'wan'
        option proto 'none'
        option device 'br-wan'

# Baby jumbo frames on the DSL interface
config device 'wan_dev'
        option macaddr '18:1e:78:##:##:##'
        option name 'dsl0'
        option mtu '1508'

# Enable the Switch
config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

# Assign VLAN1 to switch ports 0 1 2 4 and VLAN tag on port 5 (for single cable link to the router option) and the SoC NIC on port 6
config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '0 1 2 4 5t 6t'

# Assign VLAN2 to switch port 5 and tag on the SoC NIC port 6
config switch_vlan
        option device 'switch0'
        option vlan '2'
        option vid '2'
        option ports '5 6t'

# Bridge the LAN to VLAN 1
config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'
        option igmp_snooping '1'

# Bridge the VDSL VLAN 101 to VLAN 2
config device
        option name 'br-wan'
        option type 'bridge'
        list ports 'eth0.2'
        list ports 'dsl0.101'

For the WiFi you just add them to the LAN bridge, easiest done in LuCI.  Bear in mind there should be no DHCP enabled on the modem so this wont give you connectivity unless you set a static IP on the device connecting, or have it bridged into the LAN via the router like I do.

On pfSense I have a VLAN1 interface on the WAN ethernet port that bridges into the LAN so I can access the modem UI from the LAN.

Thanks for the reply. A couple of question though :

* 192.168.1.254 is your pfsense, right ?
* VLAN 101, is the VLAN used by your ISP ?
* do pfsense see your public IP ?
« Last Edit: November 22, 2021, 08:11:56 PM by nesousx »
Logged

Alex Atkin UK

  • Addicted Kitizen
  • *****
  • Posts: 5272
    • Thinkbroadband Quality Monitors
Re: Modem/Router VDSL2 Technicolor DGA4130 (BCM63138)
« Reply #1246 on: November 24, 2021, 02:53:59 AM »

Thanks for the reply. A couple of question though :

* 192.168.1.254 is your pfsense, right ?
* VLAN 101, is the VLAN used by your ISP ?
* do pfsense see your public IP ?

Correct on all the above.

As for the IP, technically you don't need to specify the gateway but I do it as it allows my to install software on OpenWRT via opkg to do things like use it as a Tor proxy.  When there's a box sat there with way more CPU power than it needs to be a bridge, I figure why not use it.

Most ISPs over here use PPPoE for the WAN, but DHCP should work just the same as you're bridging the telcos/ISPs VLAN directly to the WAN port of your router so anything that needs to happen after that point is up to your router.
« Last Edit: November 24, 2021, 02:57:14 AM by Alex Atkin UK »
Logged
Broadband: Zen Full Fibre 900 + Three 5G Routers: pfSense (Intel N100) + Huawei CPE Pro 2 H122-373 WiFi: Zyxel NWA210AX
Switches: Netgear MS510TXUP, Netgear MS510TXPP, Netgear GS110EMX My Broadband History & Ping Monitors
Pages: 1 ... 82 83 [84]
 

anything