Kitz ADSL Broadband Information
adsl spacer  
Support this site
Home Broadband ISPs Tech Routers Wiki Forum
 
     
   Compare ISP   Rate your ISP
   Glossary   Glossary
 
Please login or register.

Login with username, password and session length
Advanced search  

News:

Author Topic: Time is off - NTP not working  (Read 1561 times)

Weaver

  • Addicted Kitizen
  • *****
  • Posts: 8672
  • Retd sw dev; A&A; 4 ◊ 7km ADSL2; IPv6; Firebrick
Time is off - NTP not working
« on: March 02, 2020, 05:46:18 AM »

I have this exciting systemd-nspawn dual o/s setup on a Raspberry Pi (discussed in an earlier thread, which I need to locate really). In both the operating system containers - Raspbian 32-bit and AAarch64 Debian Buster - the displayed system time is behind the reality by 5 hours 15 mins approx (behind the true time) but nothing an integer multiple of an hour so it doesnít appear to be anything to do with time zone.

I donít know how to fix it.

I looked in /etc/ntp.conf and it references a local on-LAN ntp server which is pingable; this reference is a domain name that resolves to my Firebrick router which is an ntp server.

Iím wondering if this problem is to do with processes in the two containers both trying to use NTP client facilities and treading on each otherís toes somehow but Iím not remotely sure what Iím talking about. If thatís correct then one would have to be reconfigured slightly to get out of the way, errrm. Or something.  :-[
Logged

petef

  • Reg Member
  • ***
  • Posts: 105
Re: Time is off - NTP not working
« Reply #1 on: March 02, 2020, 02:46:51 PM »

The ntpq command line program is your friend.
Logged
 

anything