Kitz ADSL Broadband Information
adsl spacer  
Support this site
Home Broadband ISPs Tech Routers Wiki Forum
 
     
   Compare ISP   Rate your ISP
   Glossary   Glossary
 
Please login or register.

Login with username, password and session length
Advanced search  

News:

Author Topic: ZyXEL VMG8324-B10A - can't login after firmware update?  (Read 548 times)

helios

  • Just arrived
  • *
  • Posts: 4
ZyXEL VMG8324-B10A - can't login after firmware update?
« on: December 07, 2019, 09:59:22 AM »

Hi All,

New here and already asking for help!  :-[

I've recently been given a VMG8324-B10A, I was initially able to get into it with zyuser/1234 which enabled me to flash Johnson's firmware (V28-jumbo-tel-x6-stats-cmd). The previous firmware was V15 and I am keen to try the full 1500 MTU on this device.

Now I'm somewhat embarrassed to say that I can no longer get into the device. It's up and running, I can ping it and get to the web ui login but any combination of admin/admin, admin/1234, zyuser/1234 does not seem to work. I've tried via telnet too and the same is true.
I've since connected a ttl->uart usb dongle and can see the console, if I hold down the reset button I can confirm it resets the ROM-D but still I'm unable to connect.

From the CFE at boot I can see the following info:

CFE> ATSH

FW       Version       : V28-jumbo-tel-x6-stats-cmd
Bootbase Version       : V1.66 | 09/10/2015 16:03:18
Vendor Name            : ZyXEL Communications Corp.
Product Model          : VMG8324-B10A


Do I have a brick? Help!

Thanks!
Logged

ktz392837

  • Reg Member
  • ***
  • Posts: 477
Re: ZyXEL VMG8324-B10A - can't login after firmware update?
« Reply #1 on: December 07, 2019, 10:31:09 AM »

Could you be using a none oldtelnet version of the firmware and dslstats has already connected meaning your telnet attempt will not work?

If you can access the GUI doesn't appear to be bricked should be able to sort it out.  Is telnet access enabled in the web GUI?

I recently updated to Johnsons firmware and  some passwords where changed and needed to base64 decode them or hashcat them but I could still get in by telnet with admin to get the data I needed to decode the new passwords for supervisor etc
Logged

helios

  • Just arrived
  • *
  • Posts: 4
Re: ZyXEL VMG8324-B10A - can't login after firmware update?
« Reply #2 on: December 07, 2019, 11:05:24 AM »

Hi,

Thanks for the reply.

Quote from: ktz392837
link=topic=24124.msg406177#msg406177 date=1575714669
Could you be using a none oldtelnet version of the firmware and dslstats has already connected meaning your telnet attempt will not work?

I don't have dslstats running and the password doesn't work via gui or telnet. I'm wondering if I should try to flash another version via CFE. Does the image have the passwords in or are they stored somewhere else in flash?

I should add that I'm directly connected via an old laptop to the ethernet port so nothing in between and using DHCP from the device to get an address.

Thank you!
« Last Edit: December 07, 2019, 11:51:33 AM by helios »
Logged

ktz392837

  • Reg Member
  • ***
  • Posts: 477
Re: ZyXEL VMG8324-B10A - can't login after firmware update?
« Reply #3 on: December 07, 2019, 12:25:51 PM »

I don't recall anyone else reporting a problem where you could get the GUI/telnet but no passwords worked. 

If you can get to a shell I think trying to cat /var/csemu or similar (search forum) will list all valid usernames and base64 encoded passwords on the 8324/8924. 

If no one else chimes in I will dig out my notes when I feel a bit better. 

You will need some kind of correct prompt though to type the commands.

Hopefully someone more experienced in this area will be along soon.  If not I will do what I can as if you have a GUI login it doesn't seem bricked or beyond hope to me.
Logged

helios

  • Just arrived
  • *
  • Posts: 4
Re: ZyXEL VMG8324-B10A - can't login after firmware update?
« Reply #4 on: December 07, 2019, 02:20:54 PM »

Fixed!

I took the plunge and flashed via the CFE with Xmodem over serial.

After finding ATHE for help I ended up doing:
ATBR
ATER
ATUR and then upload Johnson's firmware over xmodem
ATBR
ATER
ATSR to reboot

I'm now in!

Thanks for the comments - even if it was only to convince me it wasn't bricked.
Logged

ktz392837

  • Reg Member
  • ***
  • Posts: 477
Re: ZyXEL VMG8324-B10A - can't login after firmware update?
« Reply #5 on: December 07, 2019, 03:36:14 PM »

Great news
Logged

johnson

  • Reg Member
  • ***
  • Posts: 741
Re: ZyXEL VMG8324-B10A - can't login after firmware update?
« Reply #6 on: December 08, 2019, 10:43:20 AM »

Really glad you fixed it helios.

I have never had the default passwords stop working after a flash, I should investigate and maybe start advising to change from default before flashing? I have usually changed them before flashing... hmm.
Logged

helios

  • Just arrived
  • *
  • Posts: 4
Re: ZyXEL VMG8324-B10A - can't login after firmware update?
« Reply #7 on: December 08, 2019, 12:24:35 PM »

Really glad you fixed it helios.

Me too!  ;D

I have never had the default passwords stop working after a flash, I should investigate and maybe start advising to change from default before flashing? I have usually changed them before flashing... hmm.

It's not clear to me what state this was in when it was given to me, I don't think it was locked to a provider but it was running a much older default firmware. I'd tried holding the reset button and confirmed in the console that the Rom-D was being cleared but no luck. The clear down and reflash did the trick though.

Thanks a lot for all of your efforts on building the custom firmware, it's nice to have something with proper mtu settings now! :thumbs:
Logged