Kitz ADSL Broadband Information
adsl spacer  
Support this site
Home Broadband ISPs Tech Routers Wiki Forum
 
     
   Compare ISP   Rate your ISP
   Glossary   Glossary
 
Please login or register.

Login with username, password and session length
Advanced search  

News:

Author Topic: HG630 v2 Ver.B bricked  (Read 277 times)

ehab

  • Just arrived
  • *
  • Posts: 3
HG630 v2 Ver.B bricked
« on: August 14, 2019, 04:04:50 PM »

Hello, I have a HG630 v2 Ver.B as the title says. Software version was V100R001C105B020.

I attempted to flash this file (V100R001C36B023), the _main.bin file:
https://firmware.gem-flash.com/index.php?a=downloads&b=file&id=53460

Which I thought was the same board just a different SW version, and it bricked my router. It had a document with it that stated how to get into the emergency rescue mode, by holding the reset button while powering up and setting a static IP of 192.168.0.10, then accessing 192.168.0.100, which works.

But when I attempt to flash the original firmware from here (V100R001C105B020), which is even the same ISP I'm using:
https://easy-firmware.com/index.php?a=downloads&b=file&id=119050

It says:
"New software is being programmed to the flash memory.
The DSL Router will reboot upon completion. This process will take about 2 minutes."

But just returns me to the index page after a while, and doesn't reboot or do anything.
I tried using both LAN2 and LAN1.
I tried using an old version of Firefox 12 from 2012. I tried using IE too.
I manually reboot after a while, and set it to dynamically set IP, it does get it automatically (within 192.168.1.x), and it also says my network name under the ethernet adapter, (it says unidentified network if I'm in recovery).

BUT, it cannot access the router page (192.168.1.1), it just times out.
Also, if I connect my phone line to it, the DSL led lights up, yet the internet, wifi, router page, are all down.

I don't think it flashes/reboots after flashing because while I'm in rescue mode, the LAN led is off, and in normal mode, it lights up. So after I flash the firmware and wait 2+ minutes, the LAN led stays off until I manually reboot.

Help would be greatly appreciated.
« Last Edit: August 14, 2019, 04:59:27 PM by ehab »
Logged

burakkucat

  • Global Moderator
  • Senior Kitizen
  • *
  • Posts: 26924
  • Over the Rainbow Bridge
    • The ELRepo Project
Re: HG630 v2 Ver.B bricked
« Reply #1 on: August 14, 2019, 09:27:19 PM »

Welcome to the Kitz forum.  :)

Having read through your tale of woe, it does appear that the device is not accepting the new firmware image. Unfortunately I do not have any experience of the Huawei HG630 and so I am unable to assist.

Let's see if any other members have suggestions. 
Logged
:cat:  100% Linux and, previously, Unix. Co-founder of the ELRepo Project.

Please consider making a donation to support the running of this site.

ehab

  • Just arrived
  • *
  • Posts: 3
Re: HG630 v2 Ver.B bricked
« Reply #2 on: August 15, 2019, 12:27:12 AM »

Correct, it's not accepting any firmware, but also retaining some of the old config. I find it very odd that it's not even deleting those remnants while doing a reset/holding the reset button even with a 30/30/30 cycle.

Check out the post history on this user, I have the exact same model as him, and he managed to flash fine with bricking it:
https://forum.kitz.co.uk/index.php?action=profile;area=showposts;u=10535

Logged

ehab

  • Just arrived
  • *
  • Posts: 3
Re: HG630 v2 Ver.B bricked
« Reply #3 on: August 18, 2019, 08:46:49 PM »

Anyone? Any idea? Suggestion? Something to try?
Logged