Kitz ADSL Broadband Information
adsl spacer  
Support this site
Home Broadband ISPs Tech Routers Wiki Forum
 
     
   Compare ISP   Rate your ISP
   Glossary   Glossary
 
Please login or register.

Login with username, password and session length
Advanced search  

News:

Author Topic: VLAN's and DHCPv6  (Read 328 times)

Chrysalis

  • Content Team
  • Addicted Kitizen
  • *
  • Posts: 5787
VLAN's and DHCPv6
« on: April 12, 2019, 12:52:58 AM »

I am somewhat a VLAN novice.  My knowledge with VLAN's is very basic, and I am currently completing a guest network on my setup.

Almost everything is working except now DHCPv6 is just dead.  No ip's get allocated to LAN devices.

So is there something special needed when VLAN tagging is used for DHCPv6 to function?

If needed I will type out my setup, but its a generic question which I hope would be applicable to all devices.
Logged
Sky Fiber Pro - Billion 8800NL bridge & PFSense BOX running PFSense 2.4 - ECI Cab - LINE STATISTICS CLICK HERE

Weaver

  • Addicted Kitizen
  • *****
  • Posts: 7459
  • Retd sw dev; A&A; 4 ◊ 7km ADSL2; IPv6; Firebrick
Re: VLAN's and DHCPv6
« Reply #1 on: April 12, 2019, 01:30:47 AM »

Is this DHCPv6 coming from the ISP ? Or do you have your own DHCPv6 server?
Logged

Weaver

  • Addicted Kitizen
  • *****
  • Posts: 7459
  • Retd sw dev; A&A; 4 ◊ 7km ADSL2; IPv6; Firebrick
Re: VLAN's and DHCPv6
« Reply #2 on: April 12, 2019, 01:47:20 AM »

Just a random guess - trying to think of anything that could be anything to do with VLANs, but I donít know what your RAs look like
    https://teamarin.net/2018/06/25/common-mistake-dhcpv6/
Logged

Chrysalis

  • Content Team
  • Addicted Kitizen
  • *
  • Posts: 5787
Re: VLAN's and DHCPv6
« Reply #3 on: April 12, 2019, 04:57:46 AM »

Thanks weaver.

DHCPv6 LAN side, not from isp.

I have now solved it, the issue was after I bound the LAN network on pfsense to the private VLAN (from native network device), it lost its ipv6, and I had to reinitialise the WAN for it to come back, once that was in place DHCPv6 was fine again, since my LAN DHCPv6 auto generates the first octets from the WAN assigned prefix, it cannot work without that in place, so thats why it was failing.

Also to help other newbies I will post a guide at some point, on setting up isolated subnets for things like guest wifi.  The guide will be based on pfsense/opnsense paired with a openwrt device as the AP/switch.
Logged
Sky Fiber Pro - Billion 8800NL bridge & PFSense BOX running PFSense 2.4 - ECI Cab - LINE STATISTICS CLICK HERE