Kitz ADSL Broadband Information
adsl spacer  
Support this site
Home Broadband ISPs Tech Routers Wiki Forum
 
     
   Compare ISP   Rate your ISP
   Glossary   Glossary
 
Please login or register.

Login with username, password and session length
Advanced search  

News:

Author Topic: ECI Openreach OpenWrt with sky login unable to connect to router  (Read 168 times)

FruitPolo

  • Just arrived
  • *
  • Posts: 1

I have flashed OpenWrt onto my ECI Openreach modem and have got it setup so the modem is able to ping the internet by using the wan_bridge on the modem to input my sky login credentials using the DHCP Client protocol. I cannot now get the correct settings to connect my router to the modem. The router is running DD-WRT and I seem unable, no matter what static IPs I set in relation to the modem and various settings I play with, I cannot get any connection to the modem from the router. I am starting to wonder if my setup of using the wan_bridge to have the login credentials will work at all. Does anyone have any ideas on how I can get this working? This is getting a bit beyond my skill level now with networking so I'd just like it working then once I have something working I can play around to get it setup nicely for me.
Here are my interface settings on the modem:

root@ECIOpenreachModem:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd88:f59f:8b1e::/48'

config interface 'wan_bridge'
        option type 'bridge'
        option ifname 'eth0 ptm0.101'
        option _orig_ifname 'eth0 ptm0.101'
        option _orig_bridge 'true'
        option proto 'dhcp'
        option clientid '376334636135623'                  (Partially cut out)
        option vendorid '6.14.1aN_UNI|PCBAFAST2504Nv1.0'
        option delegate '0'

config interface 'lan'
        option ifname 'eth1'
        option force_link '1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.2.1'
        option gateway '192.168.2.2'
        option dns '8.8.8.8'

config vdsl 'dsl'
        option annex 'a'
        option firmware '/lib/firmware/vdsl.bin'
        option tone 'av'
        option xfer_mode 'ptm'

config interface 'WAN'
        option ifname 'eth0'
        option _orig_ifname 'eth0'
        option _orig_bridge 'false'
        option proto 'static'
        option ipaddr '192.168.3.1'
        option netmask '255.255.255.0'
        option gateway '192.168.3.2'

And a picture of the WAN setup on the router:
« Last Edit: October 01, 2018, 12:45:41 PM by FruitPolo »
Logged
 

anything