Kitz ADSL Broadband Information
adsl spacer  
Support this site
Home Broadband ISPs Tech Routers Wiki Forum
 
     
   Compare ISP   Rate your ISP
   Glossary   Glossary
 
Please login or register.

Login with username, password and session length
Advanced search  

News:

Author Topic: Download Speed Requires a Runup!  (Read 480 times)

rbz5416

  • Member
  • **
  • Posts: 31
Download Speed Requires a Runup!
« on: September 14, 2018, 06:30:03 PM »

I've been having ongoing issues with disconnections & random periods of very high latency & packet loss. Following the latest OR visit to the cab I've now got another strange symptom. When running a speed test the reported speed climbs gradually to a peak rather than starting at full speed. Example attached.

Any ideas what might be causing this?

 
Logged

Weaver

  • Addicted Kitizen
  • *****
  • Posts: 6541
  • Retd sw dev; A&A; 4 ◊ 7km ADSL2; IPv6; Firebrick
Re: Download Speed Requires a Runup!
« Reply #1 on: September 15, 2018, 01:17:16 PM »

Is there any chance that something else could be running in the background while you are doing the speed test?

There will be various ways of checking depending on the facilities you have available. If there is nothing else, doing several pings to the first hop might be interesting. If the ping time is sometimes abnormally long then that could indicate some kind of background activity. You can find out where the first hop is by doing a traceroute / tracert to eg 8.8.8.8 and then noting the first address you see that is outside your local network.
Logged

rbz5416

  • Member
  • **
  • Posts: 31
Re: Download Speed Requires a Runup!
« Reply #2 on: September 26, 2018, 09:02:52 AM »

Thanks Weaver & apologies for the late reply, I've had more pressing issues with the line. Now they're resolved this issue remains.

Nothing happening in the background & this shows on every speed test, regardless of time of day. It's also present on a wired connection with all wireless turned off on the router & all other ethernet connections removed. Also present on a wireless test with only an iPad connected so pretty sure it's external.

The first external hop is Plusnet (84.93.253.112). There is no reply to a ping to this address, so presumably what I'm seeing is the connection trying to find an alternative route? Unless of course that box isn't allowed to reply to ping.

« Last Edit: September 26, 2018, 09:07:25 AM by rbz5416 »
Logged

Weaver

  • Addicted Kitizen
  • *****
  • Posts: 6541
  • Retd sw dev; A&A; 4 ◊ 7km ADSL2; IPv6; Firebrick
Re: Download Speed Requires a Runup!
« Reply #3 on: September 26, 2018, 11:22:04 AM »

Are you still getting packet loss when the link is not heavily loaded with traffic?
Logged

rbz5416

  • Member
  • **
  • Posts: 31
Re: Download Speed Requires a Runup!
« Reply #4 on: September 26, 2018, 11:31:23 AM »

No, apparently OR moved the connection:

KBD - Your fault has been diagnosed using the Knowledge Based Diagnostic Tool: We have identified the Circuit was built on an SFBB SVLAN experiencing high Utilisation. This circuit has been moved onto a different SFBB SVLAN with lower utilisation. Please liaise with your customer

That seems to have cured the packet loss & disconnects but introduced this slow start to a speed test. Sorry, should have mentioned that but had so many issues with this switch from BT I've kind of lost track a bit.

Previously speed test results with both BT & Plusnet were somewhat erratic in that they'd sawtooth down & back up until reaching full speed. I'll see if I can dig out an example.

I have also changed the router so should really try the HG612 as the front end I suppose.
« Last Edit: September 26, 2018, 11:42:47 AM by rbz5416 »
Logged

Weaver

  • Addicted Kitizen
  • *****
  • Posts: 6541
  • Retd sw dev; A&A; 4 ◊ 7km ADSL2; IPv6; Firebrick
Re: Download Speed Requires a Runup!
« Reply #5 on: September 26, 2018, 11:54:43 AM »

The sawtoothing thing is probably due to the behaviour of some TCP implementation if that is being used in that particular speed test. If a TCP ACK gets lost or intentionally dropped or is very much delayed then the original data packet sender end TCP software will reduce speed a lot and then recover its courage later and this is the speed sawtooth. It is annoying but just quite natural. It results from the sender overdriving the link, going too fast, until intermediate router starts being forced to drop packets and then this causes the problem. A better-designed TCP implementation will find the right speed and send just very slightly under the maximum rate so that things will remain stable.

I would go so far as to say that this is often a bogus phenomenon that just says more about the design of the speed tester or its underlying o/s than your link so it is not testing your link at all but the combination of link plus software which is possibly totally irrelevant to your particular situation with some server x that has whatever software in it. I donít think speed testers should be using TCP at all, not if the aim is to measure the link and nothing else.

Slow initial growth in transfer rate is another bogus TCP behaviour thing related to design of some TCP implementation again, plus various other environmental factors.

I do not have much respect for most speed testers as they are apparently written by morons who do not understand what they should be aiming for and are lazily just using the o/s normal facilities which are not suitable as they have totally incompatible goals that override and mess up the results.

If I ever design one it will carefully check that the link is quiet in terms of alien traffic and then slowly increase test packet send rate with carefully controlled per-packet timing, monitoring transit time all the while, so as to detect the point at which overload begins. That way the link speed can be established properly and in a way that does not depend on random o/s-internal software design decisions.
Logged

rbz5416

  • Member
  • **
  • Posts: 31
Re: Download Speed Requires a Runup!
« Reply #6 on: September 26, 2018, 12:03:46 PM »

Here's test before the port switch:



This is after:



Didn't realise I had this history & this is on the same router. So whatever it is it's down to the connection I'm now on.

For reference this is how it was before any issues started:

Logged

Weaver

  • Addicted Kitizen
  • *****
  • Posts: 6541
  • Retd sw dev; A&A; 4 ◊ 7km ADSL2; IPv6; Firebrick
Re: Download Speed Requires a Runup
« Reply #7 on: September 26, 2018, 12:20:50 PM »

So the question is why the slow rate increase of TCP. Has any software changed at either end? If not, there are various environmental factors that could make a particular TCP behave like that. I have to leave the answer to those who really know their TCP internals, but from what I have read it could be early packet loss that is causing this misbehaviour. Need a way of testing for packet loss.

Early packet loss means a bad link or bad ISP. This would cause a change from normally expected  fast initial growth to a slower linear growth rate in speed and that could be what we are seeing in those graphs. There are tweaks that have been proposed to help mitigate this.

It is very interesting but should also use lots of other speed testers as it is bogosity and nothing to do with your link at all, just a software quirk. I have seen this kind of thing before with some speed testers.

Itís important tho because packet loss is very very bad. If it cannot be fixed by fixing the line or buggy modems or bad wirelessness or the ISP sorting things out, then a change to a good ISP is required.
Logged

rbz5416

  • Member
  • **
  • Posts: 31
Re: Download Speed Requires a Runup!
« Reply #8 on: September 26, 2018, 12:33:57 PM »

The only software that's changed locally is W10 updates.

The only other change around these symptoms is a speed increase that happened around this time last year. My connection increased from around 35mbps to 43. Don't know if that was G.INP being implemented or something else.
Logged

Weaver

  • Addicted Kitizen
  • *****
  • Posts: 6541
  • Retd sw dev; A&A; 4 ◊ 7km ADSL2; IPv6; Firebrick
Re: Download Speed Requires a Runup!
« Reply #9 on: September 26, 2018, 01:08:47 PM »

Ask around here about testing for packet loss.

A simply repeated ping might show some loss, or it might be more subtle. Microsoft has the pathping program.

Packet loss could be out in the internet or even close to that speed tester in which case there is nothing to do and nothing can be done.

If pathping-ing the first hop shows a non zero packet loss then I would then talk to the ISP.
« Last Edit: September 26, 2018, 01:11:35 PM by Weaver »
Logged