Kitz ADSL Broadband Information
adsl spacer  
Support this site
Home Broadband ISPs Tech Routers Wiki Forum
   Compare ISP   Rate your ISP
   Glossary   Glossary
Please login or register.

Login with username, password and session length
Advanced search  


Author Topic: temporary failure in name resolution - err  (Read 514 times)


  • Addicted Kitizen
  • *****
  • Posts: 8283
  • Retd sw dev; A&A; 4 × 7km ADSL2; IPv6; Firebrick
temporary failure in name resolution - err
« on: October 01, 2018, 10:43:42 PM »

I got this error message when I tried to ping6 to a domain name in my Raspberry Pi running Ubuntu 18.0x, hosted by Mythic Beasts. The error went away on its own after a while
I did some digging and it seems that the system was configured to consult one single DNS server at Mythic Beasts, from the evidence of the IP address.

I would like to add some more alternative DNS servers. Must be IPv6 because the machine does not have IPv4.

I did a systemd-resolve —status to see what the servers where and could only see the one address mentioned. I looked at the file /etc/resolv.conf which told me not to edit it by hand and gave instructions about running some tool to find out the truth instead. Maze of twisty passages after that.

I tried adding the Google public IPv6 DNS servers to /etc/resolvconf/resolv.conf.d/base - not sure if that is the correct thing - but even if it is, I don’t know what to do to make it take effect, or how to test it.