Kitz ADSL Broadband Information
adsl spacer  
Support this site
Home Broadband ISPs Tech Routers Wiki Forum
 
     
   Compare ISP   Rate your ISP
 
Please login or register.

Login with username, password and session length
Advanced search  

News:

Author Topic: Strange Dose of EMI  (Read 137 times)

displaced

  • Reg Member
  • ***
  • Posts: 140
Strange Dose of EMI
« on: June 12, 2018, 10:18:02 PM »

Hello!  Thought I'd ask this here, since there's some smart cookies, and I doubt anyone will advise me to spend 500 on an AC line conditioner...

Get comfy, this is a long and likely dull story.

So, my PC is connected to a Sony AV Receiver via its multichannel input -- four 3.5mm-to-twin-RCA cables (front L/R, rear L/R, side L/R, Centre/Subwoofer).

I sat down last week to play a bit of Overwatch.  The PC's audio-out is a little weak even at 100%, so the amp's volume needs to be up at -18dB (-30dB is about right on other sources). 

When the PC's not making any sound, there's normally a little hiss.  However, this time, as soon as the GPU started doing some heavy work I got quite severe noise in the background.  The pitch and pattern changed as the screen content changed, so the GPU was clearly the source.

I thought, "How have I not noticed this before?!".  Pulled the PC out, re-seated some components, gave it a clean, sprayed some contact cleaner in a few places, and put it all back. 

The problem persisted.  I thought perhaps some component was ageing on the motherboard or GPU.  Cheapest solution would be an external USB 7.1 audio adapter.  No analog chain back to the motherboard... Sorted, I thought.

I hooked up the USB audio adapter and... still the noise, just as loud as before.

"What!?  How?!".

So I started thinking about the power supplies.  And then I wondered...

I've recently been restoring an old Commodore CDTV.  I finally finished it and connected it up properly last time I tidied-up.  It's sat on top of the AV receiver, since it's AV-unit sized.  On a hunch, I pulled the kettle-style AC connector from the back of the CDTV and... the noise stopped.  Well, it was still faintly there in the background, but definitely at an acceptable level.

----

To sum up, when the GPU on the PC is being worked hard, there's noise being generated.  Without the CDTV connected to the mains, it's at an audible, but acceptable (given the amplifier's volume setting) level.

With the CDTV connected to the mains, the same noise (with the same pattern and relationship to what's on the PC's screen) is massively louder. 

I grabbed an extension lead and plugged the CDTV into a socket in another room (same ring-main, though).  Same effect, but the noise is a little quieter.

So, clearly the CDTV's doing something.  But it's not creating its own noise. Rather, it causes amplification of noise from the PC.  Can anyone explain what's going on here?  And perhaps even a solution?  For the moment, I'm leaving the CDTV unplugged unless I want to use it.

Cheers,
Chris
Logged
Vodafone Landline+FTTC: Huawei DSLAM, HG612 modem, pfSense router, Ubiquiti access points. GigE home LAN with Netgear ProSafe switches. Mac, FreeBSD and Win10.

Weaver

  • Addicted Kitizen
  • *****
  • Posts: 5145
  • Retd sw dev; A&A; 3 7km ADSL2; IPv6; Firebrick
Re: Strange Dose of EMI
« Reply #1 on: June 12, 2018, 11:06:12 PM »

Things that can cause amplification: a resonator, or an antenna. Something plugged in or parked really close to some source might just imaginable count as one of these, but that is pretty vague and it is a stretch. I would definitely put mains purification units in. 40 is quite enough.

I use a pair of devices connected together, doubling things up because I am paranoid. One is a Belkin "Pure AV" surge protector plus hifi mains filter. This is the nearer of the two to the outside world and takes its power from the output of a small UPS made by APC. The second unit is a smaller multi-socket strip by Tacima which again is to block EMI/RFI.

I have put ferrites on the dc cables that go into my ADSL modems. It might be worth playing around with ferrites but kitizens have warned that getting the wrong spec of ferrite might make things worse or do no good. Would need to experiment and test carefully.
Logged