Kitz ADSL Broadband Information
adsl spacer  
Support this site
Home Broadband ISPs Tech Routers Wiki Forum
 
     
   Compare ISP   Rate your ISP
   Glossary   Glossary
 
Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1] 2

Author Topic: "Naming" links  (Read 3765 times)

GigabitEthernet

  • Kitizen
  • ****
  • Posts: 1950
"Naming" links
« on: September 18, 2016, 02:11:28 PM »

On this forum, to "name" a link you have to do it as per: http://wiki.simplemachines.org/smf/Url.

On other forums, you highlight the text you want to link to the URL, click the URL button and then you type in the URL into the box that appears.

Can this functionality be implemented here? :)
Logged

roseway

  • Administrator
  • Senior Kitizen
  • *
  • Posts: 39633
  • Penguins CAN fly
    • DSLstats
Re: "Naming" links
« Reply #1 on: September 18, 2016, 02:52:44 PM »

It's already implemented.

Link to the BBC

If you use the Quick Reply option, then to get this and other functionality you hit "Preview" after typing your text, then highlight the text you want to link and click the "Insert Hyperlink" button. That's what I did here.
Logged
  Eric

GigabitEthernet

  • Kitizen
  • ****
  • Posts: 1950
Re: "Naming" links
« Reply #2 on: September 18, 2016, 03:10:44 PM »

I tried that and it put URL brackets around the text.
Logged

roseway

  • Administrator
  • Senior Kitizen
  • *
  • Posts: 39633
  • Penguins CAN fly
    • DSLstats
Re: "Naming" links
« Reply #3 on: September 18, 2016, 04:02:19 PM »

Perhaps you overtyped the 'http://' in the popup box. That (or 'https://') must be retained.
Logged
  Eric

Dray

  • Kitizen
  • ****
  • Posts: 2362
Re: "Naming" links
« Reply #4 on: September 18, 2016, 04:04:21 PM »

No I get the same result - URL tags. It doesn't work.
Logged

roseway

  • Administrator
  • Senior Kitizen
  • *
  • Posts: 39633
  • Penguins CAN fly
    • DSLstats
Re: "Naming" links
« Reply #5 on: September 18, 2016, 04:44:17 PM »

I'll try again with a link to my website. It still works. Perhaps it's a browser issue.

I'm using the Quick Reply option. First I type all this text. Then I hit the Preview button. A preview of the result appears, with the original typed text below it. In the original text box, I highlight 'a link to my website', then click the 'Insert Hyperlink' button. A popup box appears with 'http://' already filled in. Retaining the 'http://' part, I append the remainder of the target URL and hit Return. Then I click 'Post'.
Logged
  Eric

Dray

  • Kitizen
  • ****
  • Posts: 2362
Re: "Naming" links
« Reply #6 on: September 18, 2016, 04:51:05 PM »

No "popup box appears with 'http://'" instead the highlighted text is surrounded by URL tags
Logged

burakkucat

  • Global Moderator
  • Senior Kitizen
  • *
  • Posts: 29871
  • Over the Rainbow Bridge
    • The ELRepo Project
Re: "Naming" links
« Reply #7 on: September 18, 2016, 05:14:16 PM »

I must be missing something.  ???

I've looked and looked but cannot see a "Quick Reply" button anywhere.  :no:
Logged
:cat:  100% Linux and, previously, Unix. Co-founder of the ELRepo Project.

Please consider making a donation to support the running of this site.

Dray

  • Kitizen
  • ****
  • Posts: 2362
Re: "Naming" links
« Reply #8 on: September 18, 2016, 05:36:46 PM »

Bottom left
Logged

burakkucat

  • Global Moderator
  • Senior Kitizen
  • *
  • Posts: 29871
  • Over the Rainbow Bridge
    • The ELRepo Project
Re: "Naming" links
« Reply #9 on: September 18, 2016, 05:44:40 PM »

Bottom left

Hmm . . . I see nothing obvious in that location.  ???

I have a number of Administrative and Moderation controls down there but nothing to do with "Quick Reply". Perhaps it is because of the way I have configured my account.  :-\
Logged
:cat:  100% Linux and, previously, Unix. Co-founder of the ELRepo Project.

Please consider making a donation to support the running of this site.

Dray

  • Kitizen
  • ****
  • Posts: 2362
Re: "Naming" links
« Reply #10 on: September 18, 2016, 05:54:04 PM »

Perhaps "Use quick reply on topic display: "
Logged

j0hn

  • Kitizen
  • ****
  • Posts: 2937
Re: "Naming" links
« Reply #11 on: September 18, 2016, 05:57:52 PM »

very bottom left. initially I never noticed it, as I was looking for it next to the last post.
Logged

burakkucat

  • Global Moderator
  • Senior Kitizen
  • *
  • Posts: 29871
  • Over the Rainbow Bridge
    • The ELRepo Project
Re: "Naming" links
« Reply #12 on: September 18, 2016, 06:01:39 PM »

It was due to how my account was configured.  :)  I had that functionality turned off.  ::)

It's on now . . . for an experiment but I might eventually turn it off, once again.
Logged
:cat:  100% Linux and, previously, Unix. Co-founder of the ELRepo Project.

Please consider making a donation to support the running of this site.

GigabitEthernet

  • Kitizen
  • ****
  • Posts: 1950
Re: "Naming" links
« Reply #13 on: September 18, 2016, 06:02:01 PM »

Fixed it. You need to enable WYSIWYG.
Logged

WWWombat

  • Kitizen
  • ****
  • Posts: 1674
Re: "Naming" links
« Reply #14 on: September 18, 2016, 06:02:45 PM »

I don't think it is to do with the "quick reply" (whose appearance is indeed controlled through a profile setting).


When you hit "reply, and get the text pane to fill in, it exists in one of two modes: one WYSIWYG, one displaying the formatting markup. The mode is controlled by a button with a red capital-A, and hovering over it displays "Toggle View".


In one mode, pressing the "Insert Hyperlink" causes the [url] markup to be added. In the other mode, a popup appears.

Edit: The reason that "quick reply" works is because the "preview" option of "quick reply" seems to drop you into WYSIWYG mode, even if you don't normally start in that mode on a standard reply.
Logged
Pages: [1] 2