Kitz ADSL Broadband Information
adsl spacer  
Support this site
Home Broadband ISPs Tech Routers Wiki Forum
 
     
   Compare ISP   Rate your ISP
   Glossary   Glossary
 
Please login or register.

Login with username, password and session length
Advanced search  

News:

Author Topic: Chrome a mess when migrating profile to new install  (Read 1941 times)

Chrysalis

  • Content Team
  • Addicted Kitizen
  • *
  • Posts: 5952
Chrome a mess when migrating profile to new install
« on: February 05, 2016, 10:50:16 PM »

A unexpected hiccup occured with my chrome installation when migrating from win7 to win8.1.

I was expecting it to be problem free like firefox(cyberfox) by simply keeping hold of the profile folder.

It turned out to be very messy, so this is a warning for those who might do this in future.

I made a backup of my %appdata%/chrome folder.  Which has the user profile inside it amongst some other things.

When I first launched chrome the sign of trouble was there when none of my tabs loaded, and also no signs of extensions.  However it was not a brand new profile because bookmarks and history were intact.

I did lots of testing including trying older backups, and grabbing the folder again from macrium reflect image backups (great backup app by the way) but the same issue occured.

The issue specifically was in my case two things.

Upon launch of chrome all extensions were deleted (including default ones).  However most extension settings/data remained intact (which helped later).
The chrome preferences were been reported by chrome as corrupt and as a result it was setting some but not all preferences back to default.

I was able to recover all my tabs because each tab window was in the browser history, so one click restored a window of tabs, repeated 4 more times for all 5 windows.
The specific file that triggered the corrupt error (as I tested one file at time) was "secure preferences" from what I can see this stores security related preferences for each site, e.g. what cookies are allowed, if flash is allowed etc.  I will need to accumulate these settings again over time, I couldnt get it to work even with dozens of copies of the file from backups.
I also couldnt get backups of my extensions to work, everything I tried was same result, chrome automatically wiping them all on first launch.
I also discovered all saved passwords were lost and old cookies appear to not be working (file stayed intact but cookies arent keeping me logged into forums etc.)
I couldnt remember names of all extensions I was using so I copied and pasted the long numerical id of each extension into google which loaded the appropriate webstore page and I eventually reinstalled most of them.  All the webstore one's had settings intact which eased pain significantly.
Youtube centre which I installed manually had lost its settings.
Zoom settings stayed intact.
One extension is misbehaving, http/2 indicator, its using a weird icon instead of the normal one to show http/2 status and not yet found why its broken which is annoying.

I have finally got chrome in a reasonable state aside from the http/2 extension but I am guessing if I have to migrate it again the same issues will occur. :(
Logged
AAISP - Billion 8800NL bridge & PFSense BOX running PFSense 2.4 - ECI Cab - LINE STATISTICS CLICK HERE

jid

  • Content Team
  • Kitizen
  • *
  • Posts: 1945
Re: Chrome a mess when migrating profile to new install
« Reply #1 on: February 16, 2016, 06:15:15 PM »

I have signed in to Chrome using my Gmail account, and whenever I log in to a new machine, all the profile/extensions/favourites/history are automatically synced :) Much easier I found than trying to manually copy over the profile.
Logged
Kind Regards
Jamie

BT FTTP - 75meg | Sky Q |  Bridgend Weather

Chrysalis

  • Content Team
  • Addicted Kitizen
  • *
  • Posts: 5952
Re: Chrome a mess when migrating profile to new install
« Reply #2 on: February 17, 2016, 11:29:52 PM »

yeah I have no doubt that works, but I dont want to use a online syncing system.
Logged
AAISP - Billion 8800NL bridge & PFSense BOX running PFSense 2.4 - ECI Cab - LINE STATISTICS CLICK HERE
 

anything