Kitz ADSL Broadband Information
adsl spacer  
Support this site
Home Broadband ISPs Tech Routers Wiki Forum
 
     
   Compare ISP   Rate your ISP
   Glossary   Glossary
 
Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: 1 ... 7 8 [9] 10 11 ... 26

Author Topic: OpenWrt (Chaos Calmer r46559) for ECI/r v1 & v2 - Update: G.INP/ReTX Support  (Read 270630 times)

currytop

  • Reg Member
  • ***
  • Posts: 114
Re: OpenWrt (Chaos Calmer r46559) for ECI/r v1 & v2 - Update: G.INP/ReTX Support
« Reply #120 on: September 01, 2015, 01:15:50 PM »

Quote
   wget http://vanquishsolutions.co.uk/openwrt/VG3503J/update.sh && chmod +x updates.sh && ./updates.sh

Small typo... change updates.sh to update.sh

Steve
Logged

jsamuel

  • Reg Member
  • ***
  • Posts: 117
Re: OpenWrt (Chaos Calmer r46559) for ECI/r v1 & v2 - Update: G.INP/ReTX Support
« Reply #121 on: September 01, 2015, 01:46:31 PM »

ah, well spotted :)
Logged

GigabitEthernet

  • Kitizen
  • ****
  • Posts: 2243
Re: OpenWrt (Chaos Calmer r46559) for ECI/r v1 & v2 - Update: G.INP/ReTX Support
« Reply #122 on: September 01, 2015, 05:01:18 PM »

If you can hold down the header pins, you don't actually need to do any soldering at all.
Logged

currytop

  • Reg Member
  • ***
  • Posts: 114
Re: OpenWrt (Chaos Calmer r46559) for ECI/r v1 & v2 - Update: G.INP/ReTX Support
« Reply #123 on: September 01, 2015, 08:51:00 PM »

Any ideas on getting jsamuel's OpenWRT system to assign a working static IP address on eth0/LAN1? My last post on the subject looks a little garbled!  :P

I can edit /etc/config/network and assign a static IP to 'lan' using eth0
Code: [Select]
config interface 'lan'                                                               
        option ifname 'eth0'                                                         
        option force_link '1'                                                         
        option proto 'static'                                                         
        option ipaddr '192.168.1.3'                                                   
        option gateway 192.168.1.1                                                   
        option netmask '255.255.255.0'                                               
        option ip6assign '60'                                                         
        option dns '208.67.222.222 208.67.220.220'
and the IP address applies correctly following a reboot, but no IP traffic will flow across eth0.

If I remove eth0 from the bridge using the console
Code: [Select]
brctl delif br-wan_bridge eth0I can then ping successfully and access the Luci web interface via eth0/LAN1.

Having done so I can then add eth0 back to the bridge
Code: [Select]
brctl addif br-wan_bridge eth0 and it still all works correctly!

If I assign a static address to the wan bridge interface 'wan_bridge'
Code: [Select]
config interface 'wan_bridge'
        option 'type'    'bridge'                                                     
        option 'proto'   'static'                                                     
        option 'ifname'  'eth0 ptm0.101'                                             
        option 'auto'    '1'                                                         
        option ipaddr '192.168.1.3'                                                   
        option gateway 192.168.1.1'                                                   
        option netmask '255.255.255.0'                                               
        option ip6assign '60'                                                         
        option dns '208.67.222.222 208.67.220.220'                                   
 
then the assignment succeeds and the modem is immediately accessible via eth0 after booting. But I don't know which interface will be assigned the wan IP address when PPPoE starts up. Is it wan_bridge or ptm0.101? If anyone has their ECI configured and working in this fashion could could they report back the results of 'ifconfig'? I'd rather not disconnect my HG612 for a while.

If I can get it working I'll check the resultant inbound security from the Internet.

Steve
Logged

jsamuel

  • Reg Member
  • ***
  • Posts: 117
Re: OpenWrt (Chaos Calmer r46559) for ECI/r v1 & v2 - Update: G.INP/ReTX Support
« Reply #124 on: September 01, 2015, 09:06:42 PM »

I'm not entirely sure what you want to do?  :'( sorry.

can you paste your whole config?
Logged

currytop

  • Reg Member
  • ***
  • Posts: 114
Re: OpenWrt (Chaos Calmer r46559) for ECI/r v1 & v2 - Update: G.INP/ReTX Support
« Reply #125 on: September 01, 2015, 10:23:24 PM »

Your default OpenWRT config has the PPPoE connection to the router on LAN1/eth0, and administration access on LAN2/eth1/192.168.1.1 thus requiring a second Ethernet connection. I have masquerade rules configured on my router that would allow access from my LAN through the router via the same interface as used for PPPoE.

I've had this working successfully on the original (well slightly modified) ECI firmware.

However for the purpose of testing admin connectivity, I've simply connected the modem LAN1 connection to my house LAN without the VDSL cable attached. The attached files are two of the various /etc/config/network configurations I've been trying.

'lan1.txt' results in an IP address assigned to eth0, but eth0 IP traffic doesn't flow until eth0 is removed from the wan bridge using the console cli. This is as I described before. Your config suggestion in post #76 results in exactly the same behaviour both regarding ip assignment and no-worky.

'lan2.txt' assigns an address to the wan bridge device instead, and does allow immediate admin access via eth0 following reboot, but I didn't want to interfere with any PPPoE daemon wan IP address assignment.

Oops - just realised that the PPPoE endpoint is on the router so shouldn't be an issue with WAN IP allocation.

The console cli is simply a serial port connection. I hope that's clearer?

Steve
« Last Edit: September 01, 2015, 11:19:19 PM by currytop »
Logged

GigabitEthernet

  • Kitizen
  • ****
  • Posts: 2243
Re: OpenWrt (Chaos Calmer r46559) for ECI/r v1 & v2 - Update: G.INP/ReTX Support
« Reply #126 on: September 01, 2015, 10:55:17 PM »

I've been wondering how to implement currytop's setup too and thus far have been unable to do so :(
Logged

jsamuel

  • Reg Member
  • ***
  • Posts: 117
Re: OpenWrt (Chaos Calmer r46559) for ECI/r v1 & v2 - Update: G.INP/ReTX Support
« Reply #127 on: September 01, 2015, 11:03:20 PM »

Ah. I see what you mean now.

Can you try this?

Code: [Select]
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd88:f59f:8b1e::/48'

config interface 'wan'
        option ifname 'eth0'
        option force_link '1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option gateway 192.168.1.2
        option netmask '255.255.255.0'
        option ip6assign '60'
        option dns '208.67.222.222 208.67.220.220'

config interface 'wan_bridge'
        option 'type'    'bridge'
        option 'proto'   'none'
        option 'ifname'  'eth0 ptm0.101'
        option 'auto'    '1'

config interface 'lan'
        option ifname 'eth1'
        option force_link '1'

config vdsl 'dsl'
        option annex 'a'
        option firmware '/lib/firmware/vdsl.bin'
        option tone 'av'
        option xfer_mode 'ptm'

Also check your /etc/config/firewall

Code: [Select]
config zone
        option name             lan
        list   network          'lan'
        option input            ACCEPT
        option output           ACCEPT
        option forward          ACCEPT

config zone
        option name             wan
        list   network          'wan'
        list   network          'wan6'
        option input            ACCEPT
        option output           ACCEPT
        option forward          ACCEPT
        option masq             1
        option mtu_fix          1

config forwarding
        option src              lan
        option dest             wan
Logged

currytop

  • Reg Member
  • ***
  • Posts: 114
Re: OpenWrt (Chaos Calmer r46559) for ECI/r v1 & v2 - Update: G.INP/ReTX Support
« Reply #128 on: September 01, 2015, 11:17:58 PM »

I've been wondering how to implement currytop's setup too and thus far have been unable to do so :(
Try a version of the above attached lan2.txt to suit your network and it might work. I think I gave some example masquerade rules for a typical router a few months ago. To prove the point you could try it on a ECI already synced but move the ethernet cable coming from LAN1 onto your house LAN. That will test without needing masquerade rules. You'll lose Internet connectivity but not disturb the DLM/sync.

On the ECI either via serial or telnet/ssh on LAN2:-
Code: [Select]
ifconfig eth0 192.168.1.3
brctl delif br-wan_bridge eth0

and then from a machine on your LAN
Code: [Select]
ping 192.168.1.3

Adjust addresses to suit your LAN.

Restore the wan bridge:-
Code: [Select]
brctl addif br-wan_bridge eth0

and I think it should still work.

Either reboot the ECI to restore normal functionality or I can give cli commands to do it.

Make sure you don't have overlapping addresses on LAN1/LAN2. I simply temporarily disabled LAN2 for testing by setting eth1 to 0.0.0.0

Steve
Logged

currytop

  • Reg Member
  • ***
  • Posts: 114
Re: OpenWrt (Chaos Calmer r46559) for ECI/r v1 & v2 - Update: G.INP/ReTX Support
« Reply #129 on: September 01, 2015, 11:27:56 PM »

Posts crossed!

jsamuel - your last suggestion is the same as you mentioned in post #76 and I've already tried it. The ip address gets correctly assigned to eth0, but no ip traffic will flow through it.

Simply removing eth0 from the wan_bridge using the cli gets things working using the already assigned address. Restore eth0 to the wan_bridge and it still works as needed. That's why I haven't looked at the firewall since things work after doing this.

It's as if eth0 needs to have an address assigned before adding to the bridge in order to get routing via eth0.

lan2.txt shows an address assigned directly to the bridge interface and that does work, although I haven't tried it on a live system with a functioning VDSL connection.

Steve
Logged

jsamuel

  • Reg Member
  • ***
  • Posts: 117
Re: OpenWrt (Chaos Calmer r46559) for ECI/r v1 & v2 - Update: G.INP/ReTX Support
« Reply #130 on: September 01, 2015, 11:39:07 PM »

My apologies.

There's no wan_bridge in the firewall, which is probably why it works that way too. although it does seem strange it would work given it's bridged to the PTM vlan.   :o

Both eth1/eth0 have different drivers, so you may experience put through issues if you're switching eth* around.
eth0 uses phy11
eth1 uses phy13
Logged

currytop

  • Reg Member
  • ***
  • Posts: 114
Re: OpenWrt (Chaos Calmer r46559) for ECI/r v1 & v2 - Update: G.INP/ReTX Support
« Reply #131 on: September 02, 2015, 08:35:52 AM »

There's no wan_bridge in the firewall, which is probably why it works that way too. although it does seem strange it would work given it's bridged to the PTM vlan.   :o

Thanks for looking.  :)

Quote
Both eth1/eth0 have different drivers, so you may experience put through issues if you're switching eth* around.
eth0 uses phy11
eth1 uses phy13

OK - although not a problem in this case since eth1 won't be used. Only tiny issue is that eth0 carries both PPPoE traffic and administration/monitoring traffic, but unless you're trying to max out a 100Mbs line I can't see it mattering.

I feel that my lan2.txt experiment might well work as I want, since I had completely forgotten the PPPoE link is terminated within the router. i.e. the WAN address is assigned to the router ethernet interface. I'll try it when I get time - not for a while though.

Steve
Logged

phi2008

  • Reg Member
  • ***
  • Posts: 420
Re: OpenWrt (Chaos Calmer r46559) for ECI/r v1 & v2 - Update: G.INP/ReTX Support
« Reply #132 on: September 02, 2015, 10:45:09 AM »

I get an out of memory error trying to run the update script -

Quote
Signature check passed.
Installing muninlite (1.0.4-6) to root...
Downloading http://vanquishsolutions.co.uk/openwrt/VG3503J/packages/packages/muninlite_1.0.4-6_lantiq.ipk.
Collected errors:
 * xsystem: wget: vfork: Out of memory.
 * opkg_download: Failed to download http://vanquishsolutions.co.uk/openwrt/VG3503J/packages/packages/muninlite_1.0.4-6_lantiq.ipk, wget returned -1.
 * opkg_install_pkg: Failed to download muninlite. Perhaps you need to run 'opkg update'?
 * opkg_install_cmd: Cannot install package muninlite.
Connecting to vanquishsolutions.co.uk (104.28.28.73:80)
munin-node           100% |***************************************************| 28549   0:00:00 ETA
muninlite: Updated /usr/sbin/munin-node
root@OpenWrt:~#

Quote
root@OpenWrt:~# opkg update
Downloading http://vanquishsolutions.co.uk/openwrt/VG3503J/packages/base/Packages.gz.
Downloading http://vanquishsolutions.co.uk/openwrt/VG3503J/packages/base/Packages.sig.
Signature check failed.
Remove wrong Signature file.
Downloading http://vanquishsolutions.co.uk/openwrt/VG3503J/packages/luci/Packages.gz.
Downloading http://vanquishsolutions.co.uk/openwrt/VG3503J/packages/luci/Packages.sig.
Signature check failed.
Remove wrong Signature file.
Downloading http://vanquishsolutions.co.uk/openwrt/VG3503J/packages/management/Packages.gz.
Downloading http://vanquishsolutions.co.uk/openwrt/VG3503J/packages/management/Packages.sig.
Signature check failed.
Remove wrong Signature file.
Downloading http://vanquishsolutions.co.uk/openwrt/VG3503J/packages/packages/Packages.gz.
Downloading http://vanquishsolutions.co.uk/openwrt/VG3503J/packages/packages/Packages.sig.
Signature check failed.
Remove wrong Signature file.
Downloading http://vanquishsolutions.co.uk/openwrt/VG3503J/packages/routing/Packages.gz.
Downloading http://vanquishsolutions.co.uk/openwrt/VG3503J/packages/routing/Packages.sig.
Signature check failed.
Remove wrong Signature file.
Downloading http://vanquishsolutions.co.uk/openwrt/VG3503J/packages/telephony/Packages.gz.
Downloading http://vanquishsolutions.co.uk/openwrt/VG3503J/packages/telephony/Packages.sig.
Signature check failed.
Remove wrong Signature file.
Collected errors:
 * xsystem: wget: vfork: Out of memory.
 * opkg_download: Failed to download http://vanquishsolutions.co.uk/openwrt/VG3503J/packages/base/Packages.gz, wget returned -1.
 * xsystem: wget: vfork: Out of memory.
 * opkg_download: Failed to download http://vanquishsolutions.co.uk/openwrt/VG3503J/packages/base/Packages.sig, wget returned -1.
 * xsystem: wget: vfork: Out of memory.
 * opkg_download: Failed to download http://vanquishsolutions.co.uk/openwrt/VG3503J/packages/luci/Packages.gz, wget returned -1.
 * xsystem: wget: vfork: Out of memory.
 * opkg_download: Failed to download http://vanquishsolutions.co.uk/openwrt/VG3503J/packages/luci/Packages.sig, wget returned -1.
 * xsystem: wget: vfork: Out of memory.
 * opkg_download: Failed to download http://vanquishsolutions.co.uk/openwrt/VG3503J/packages/management/Packages.gz, wget returned -1.
 * xsystem: wget: vfork: Out of memory.
 * opkg_download: Failed to download http://vanquishsolutions.co.uk/openwrt/VG3503J/packages/management/Packages.sig, wget returned -1.
 * xsystem: wget: vfork: Out of memory.
 * opkg_download: Failed to download http://vanquishsolutions.co.uk/openwrt/VG3503J/packages/packages/Packages.gz, wget returned -1.
 * xsystem: wget: vfork: Out of memory.
 * opkg_download: Failed to download http://vanquishsolutions.co.uk/openwrt/VG3503J/packages/packages/Packages.sig, wget returned -1.
 * xsystem: wget: vfork: Out of memory.
 * opkg_download: Failed to download http://vanquishsolutions.co.uk/openwrt/VG3503J/packages/routing/Packages.gz, wget returned -1.
 * xsystem: wget: vfork: Out of memory.
 * opkg_download: Failed to download http://vanquishsolutions.co.uk/openwrt/VG3503J/packages/routing/Packages.sig, wget returned -1.
 * xsystem: wget: vfork: Out of memory.
 * opkg_download: Failed to download http://vanquishsolutions.co.uk/openwrt/VG3503J/packages/telephony/Packages.gz, wget returned -1.
 * xsystem: wget: vfork: Out of memory.
 * opkg_download: Failed to download http://vanquishsolutions.co.uk/openwrt/VG3503J/packages/telephony/Packages.sig, wget returned -1.
root@OpenWrt:~#
« Last Edit: September 02, 2015, 10:48:13 AM by phi2008 »
Logged

currytop

  • Reg Member
  • ***
  • Posts: 114
Re: OpenWrt (Chaos Calmer r46559) for ECI/r v1 & v2 - Update: G.INP/ReTX Support
« Reply #133 on: September 02, 2015, 12:19:30 PM »

I get an out of memory error trying to run the update script -
Just a thought - I think there is a memory leak which gradually eats up available memory, maybe in the Luci web server which reports gradually reducing available memory on the status page. In my case it may well be because no VDSL line is attached so there are repeated errors reported. I haven't investigated it.

A reboot would fix it temporarily.

Steve
Logged

jsamuel

  • Reg Member
  • ***
  • Posts: 117
Re: OpenWrt (Chaos Calmer r46559) for ECI/r v1 & v2 - Update: G.INP/ReTX Support
« Reply #134 on: September 02, 2015, 01:22:44 PM »

I have oddly seen this before too. Simply rerunning the script (opkg update) will sort it.
currytop that is the case, when there's no VDSL connected it will notify you every second until it is, probably eating memory in the process.

Code: [Select]
[283543.300000] /home/dev/firmware/openwrt/build_dir/target-mips_34kc+dsp_musl-1.1.10/linux-lantiq_xrx200/ltq-ptm-vr9/ifxmips_ptm_vdsl.c:281:ptm_hard_start_xmit: not in showtime
[283543.316000] /home/dev/firmware/openwrt/build_dir/target-mips_34kc+dsp_musl-1.1.10/linux-lantiq_xrx200/ltq-ptm-vr9/ifxmips_ptm_vdsl.c:281:ptm_hard_start_xmit: not in showtime
[283543.460000] enter showtime
[283543.468000] enter showtime

There's some issues with LuCI that I know of such as Lua hogging CPU on the status page, but I've yet to come across memory issues except with those for opkg.
« Last Edit: September 02, 2015, 01:25:08 PM by jsamuel »
Logged
Pages: 1 ... 7 8 [9] 10 11 ... 26
 

anything