Kitz ADSL Broadband Information
adsl spacer  
Support this site
Home Broadband ISPs Tech Routers Wiki Forum
 
     
   Compare ISP   Rate your ISP
   Glossary   Glossary
 
Please login or register.

Login with username, password and session length
Advanced search  

News:

Author Topic: Connection Stats Frozen/Not Updating  (Read 3661 times)

unconnected

  • Just arrived
  • *
  • Posts: 2
Connection Stats Frozen/Not Updating
« on: July 10, 2014, 08:20:05 PM »

First of all, I wanted to thank the authors of this software as till now it's been a delight to use :)

Unfortunately my setup has stopped working :(

I noticed that 2 days ago my connection stats tab wasn't changing and can confirm as much from the "latests stats obtained at" value.

Here is where I think it's going wrong:

10/07/2014 14:00:03.277 - Start of Current Stats Harvesting
10/07/2014 14:00:03.652 - The program full path is      C:\HG612_Modem_Stats\Scripts\HG612_current_stats.exe
10/07/2014 14:00:03.652 - The program directory path is C:\HG612_Modem_Stats\Scripts
10/07/2014 14:00:03.652 - DEBUG_COMMENTS = YES
10/07/2014 14:00:03.652 - Temp File CURRENT-ISRUNNING-140003-277 was created
10/07/2014 14:00:03.652 - Before checking for RESYNC or SCHEDULED events, Delay_snapshot_data_harvest_seconds = 0
10/07/2014 14:00:03.652 - A SCHEDULED run was detected via HG612_stats.exe. Initial Pause setting from ini file = NO
10/07/2014 14:00:03.652 - Pause setting for this instance only has been forced to be NO
10/07/2014 14:00:03.652 - After checking for RESYNC or SCHEDULED events, Delay_snapshot_data_harvest_seconds = 0
10/07/2014 14:00:03.652 - malloc() O.K.
10/07/2014 14:00:03.652 - Initializing Winsock
10/07/2014 14:00:03.652 - WSAStartup() SUCCESSFUL!!!
10/07/2014 14:00:03.652 - Starting getaddrinfo()
10/07/2014 14:00:03.652 - getaddrinfo() O.K.
10/07/2014 14:00:03.652 - Starting socket()
10/07/2014 14:00:03.652 - socket() O.K.
10/07/2014 14:00:03.652 - Starting connect()
10/07/2014 14:00:03.652 - connect() O.K.
10/07/2014 14:00:04.746 - About to reply(xdslcmd info --stats)
10/07/2014 14:00:04.746 - reply(xdslcmd info --stats) O.K.
10/07/2014 14:00:05.402 - get_data() for --stats O.K.
10/07/2014 14:00:05.402 - About to determine the xDSL mode
10/07/2014 14:00:05.402 - ERROR!! - Unable to determine the xDSL mode.
10/07/2014 14:00:05.402 - About to close (sockfd)
10/07/2014 14:00:05.402 - About to WSACleanup()
10/07/2014 14:00:05.433 - About to free(txbuf)
10/07/2014 14:00:05.433 - About to free(rxbuf)
10/07/2014 14:00:05.433 - CURRENT-ISRUNNING-140003-277 DELETED
10/07/2014 14:00:05.433 - Auto_graph_Snapshot_data = YES, now graphing snapshot stats
10/07/2014 14:00:05.433 - Successfully changed directory to C:\HG612_Modem_Stats\Current_Stats\Current_Stats_20140710-1400-SCHEDULED
10/07/2014 14:00:05.433 - Pause_after_obtaining_snapshot_data = NO
10/07/2014 14:00:05.433 - GRAPHING_COMMAND = "C:\HG612_Modem_Stats\Scripts\GRAPH6.exe"
10/07/2014 14:00:05.512 - Snapshot graphs should now have been plotted
10/07/2014 14:00:05.512 - End of HG612_current_stats.exe program, closing ERROR.LOG


And this is the same logging events before it started going wrong:

07/07/2014 22:00:04.482 - Start of Current Stats Harvesting
07/07/2014 22:00:04.888 - The program full path is      C:\HG612_Modem_Stats\Scripts\HG612_current_stats.exe
07/07/2014 22:00:04.888 - The program directory path is C:\HG612_Modem_Stats\Scripts
07/07/2014 22:00:04.888 - DEBUG_COMMENTS = YES
07/07/2014 22:00:04.888 - Temp File CURRENT-ISRUNNING-220004-482 was created
07/07/2014 22:00:04.888 - Before checking for RESYNC or SCHEDULED events, Delay_snapshot_data_harvest_seconds = 0
07/07/2014 22:00:04.888 - A SCHEDULED run was detected via HG612_stats.exe. Initial Pause setting from ini file = NO
07/07/2014 22:00:04.888 - Pause setting for this instance only has been forced to be NO
07/07/2014 22:00:04.888 - After checking for RESYNC or SCHEDULED events, Delay_snapshot_data_harvest_seconds = 0
07/07/2014 22:00:04.888 - malloc() O.K.
07/07/2014 22:00:04.888 - Initializing Winsock
07/07/2014 22:00:04.903 - WSAStartup() SUCCESSFUL!!!
07/07/2014 22:00:04.903 - Starting getaddrinfo()
07/07/2014 22:00:04.903 - getaddrinfo() O.K.
07/07/2014 22:00:04.903 - Starting socket()
07/07/2014 22:00:04.903 - socket() O.K.
07/07/2014 22:00:04.903 - Starting connect()
07/07/2014 22:00:04.903 - connect() O.K.
07/07/2014 22:00:05.982 - About to reply(xdslcmd info --stats)
07/07/2014 22:00:05.982 - reply(xdslcmd info --stats) O.K.
07/07/2014 22:00:06.216 - get_data() for --stats O.K.
07/07/2014 22:00:06.216 - Modem in use = HG610 or HG612
07/07/2014 22:00:06.216 - About to determine the xDSL mode
07/07/2014 22:00:06.216 - About to parse_stats()
07/07/2014 22:00:06.216 - parse_stats completed
07/07/2014 22:00:06.216 - VDSL2 mode detected so about to reply(xdslcmd info --pbParams)
07/07/2014 22:00:06.216 - reply(xdslcmd info --pbParams) O.K.
07/07/2014 22:00:06.419 - get_data() for --pbParams O.K.
07/07/2014 22:00:06.419 - About to parse_pbParams_data()
07/07/2014 22:00:06.419 - parse_pbParams_data() completed
07/07/2014 22:00:06.419 - reply(xdslcmd info --Bits) O.K.
07/07/2014 22:00:06.966 - get_data() for --Bits O.K.
07/07/2014 22:00:06.966 - reply(xdslcmd info --linediag) O.K.
07/07/2014 22:00:08.747 - get_data() for --linediag O.K.
07/07/2014 22:00:08.747 - reply(xdslcmd info --show) O.K.
07/07/2014 22:00:08.966 - get_data() for --show O.K.
07/07/2014 22:00:08.966 - reply(xdslcmd --version) O.K.
07/07/2014 22:00:08.997 - get_data() for --version O.K.
07/07/2014 22:00:08.997 - parse_version() completed
07/07/2014 22:00:09.044 - About to exit Busybox
07/07/2014 22:00:09.044 - Busybox exited
07/07/2014 22:00:09.263 - About to exit ATP
07/07/2014 22:00:09.263 - ATP exited
07/07/2014 22:00:09.263 - About to close (sockfd)
07/07/2014 22:00:09.263 - About to WSACleanup()
07/07/2014 22:00:09.278 - About to free(txbuf)
07/07/2014 22:00:09.278 - About to free(rxbuf)
07/07/2014 22:00:09.278 - CURRENT-ISRUNNING-220004-482 DELETED
07/07/2014 22:00:09.278 - Auto_graph_Snapshot_data = YES, now graphing snapshot stats
07/07/2014 22:00:09.278 - Successfully changed directory to C:\HG612_Modem_Stats\Current_Stats\Current_Stats_20140707-2200-SCHEDULED
07/07/2014 22:00:09.278 - Pause_after_obtaining_snapshot_data = NO
07/07/2014 22:00:09.278 - GRAPHING_COMMAND = "C:\HG612_Modem_Stats\Scripts\GRAPH6.exe"
07/07/2014 22:00:09.435 - Snapshot graphs should now have been plotted
07/07/2014 22:00:09.435 - End of HG612_current_stats.exe program, closing ERROR.LOG


I've tried googling/searching this forum for anything related to the xDSL error but no luck and clicked the "Run snapshot button numerous times". The only thing I can think of is related to this picture:



The FEC errors total value may have overflowed and broken something? (and yes, I know it's a very large value!)

Any help in troubleshooting would be greatly appreciated! :)
Logged

NewtronStar

  • Kitizen
  • ****
  • Posts: 4873
Re: Connection Stats Frozen/Not Updating
« Reply #1 on: July 10, 2014, 09:30:49 PM »

I don't think having 3 billion FEC errors would break the Modem_stats GUI as 11 months ago my FEC errors went upto 4.5 billion when I was using homeplugs.

Will wait for Ronski to look into your issue.
« Last Edit: July 10, 2014, 09:39:56 PM by NewtronStar »
Logged

burakkucat

  • Global Moderator
  • Senior Kitizen
  • *
  • Posts: 36463
  • Over the Rainbow Bridge
    • The ELRepo Project
Re: Connection Stats Frozen/Not Updating
« Reply #2 on: July 10, 2014, 09:58:15 PM »

N*Star, I do not have any experience in using the utility but from my reading of the logfile extract it appears to be B*Eagle1's harvesting code that has reported the error "Unable to determine the xDSL mode.:-\
Logged
:cat:  100% Linux and, previously, Unix. Co-founder of the ELRepo Project.

Please consider making a donation to support the running of this site.

NewtronStar

  • Kitizen
  • ****
  • Posts: 4873
Re: Connection Stats Frozen/Not Updating
« Reply #3 on: July 10, 2014, 11:31:05 PM »

N*Star, I do not have any experience in using the utility but from my reading of the logfile extract it appears to be B*Eagle1's harvesting code that has reported the error "Unable to determine the xDSL mode.:-\

Yes B*CAT I can see the Unable to determine the xDSL mode in red

In that case would ask unconnected to refresh versions and updates and install any update
Logged

Bald_Eagle1

  • Helpful
  • Kitizen
  • *
  • Posts: 2721
Re: Connection Stats Frozen/Not Updating
« Reply #4 on: July 10, 2014, 11:35:46 PM »

The log file extract is indeed from my program.


@ unconnected,

I see you are using the latest version of Ronki's GUI.

This version will also update the data harvesting/graphing programs, either to v 3.0.0.0 as per full package via the dwnload link at http://www.freewarefiles.com/HG612-Modem-Stats_program_84567.html

Or if enabling the 'Receive beta updates' option in the GUI to beta versions 3.0.0.1

which versions are being displayed in the 'Help & About' tab of the GUI?

If recently updated, which versions were you previously using?



BT have very recently remotely updated the HG612's software (not firmware) for users that have NOT disabled the BT agent.

It is quite possible that happened to your modem, maybe mid-way through one of my programs' data harvest.
That could have caused one or other of the programs to end up 'stuck' & thus not progressing beyond the "Unable to determine the xDSL mode." stage.

You could check for any 'stuck' programs via Windows Task Manager, ensuring 'Show processes from all users' is ticked.


There may be some clues as to where it started to fail in the CURRENT_ERROR.LOG_file_ERROR.TXT and ONGOING_ERROR.LOG_file_ERROR.TXT files.



Going off the appearance of your GUI screenshot, it appears that you are running XP.
Is that the case?

A connection I am currently remotely monitoring had the programs updated to v 3.0.0.1 last night & they are still running without any issues.

This from when it worked O.K. seems to suggest you were still using a very old modem firmware version at 7th July:-

Modem in use = HG610 or HG612





Did this folder contain a Plink log with a size of around 330 KB:-

C:\HG612_Modem_Stats\Current_Stats\Current_Stats_20140710-1400-SCHEDULED

I suspect it was either absent or it contained very little data.



If your modem's firmware has been updated by BT & if you are still running very old versions of my programs, they will fail as the format of the data from the modem is incompatible with the older programs.

Logged

unconnected

  • Just arrived
  • *
  • Posts: 2
Re: Connection Stats Frozen/Not Updating
« Reply #5 on: July 11, 2014, 01:18:32 AM »

The log file extract is indeed from my program.


@ unconnected,

I see you are using the latest version of Ronki's GUI.

This version will also update the data harvesting/graphing programs, either to v 3.0.0.0 as per full package via the dwnload link at http://www.freewarefiles.com/HG612-Modem-Stats_program_84567.html

Or if enabling the 'Receive beta updates' option in the GUI to beta versions 3.0.0.1

which versions are being displayed in the 'Help & About' tab of the GUI?

If recently updated, which versions were you previously using?



BT have very recently remotely updated the HG612's software (not firmware) for users that have NOT disabled the BT agent.

It is quite possible that happened to your modem, maybe mid-way through one of my programs' data harvest.
That could have caused one or other of the programs to end up 'stuck' & thus not progressing beyond the "Unable to determine the xDSL mode." stage.

You could check for any 'stuck' programs via Windows Task Manager, ensuring 'Show processes from all users' is ticked.


There may be some clues as to where it started to fail in the CURRENT_ERROR.LOG_file_ERROR.TXT and ONGOING_ERROR.LOG_file_ERROR.TXT files.



Going off the appearance of your GUI screenshot, it appears that you are running XP.
Is that the case?

A connection I am currently remotely monitoring had the programs updated to v 3.0.0.1 last night & they are still running without any issues.

This from when it worked O.K. seems to suggest you were still using a very old modem firmware version at 7th July:-

Modem in use = HG610 or HG612





Did this folder contain a Plink log with a size of around 330 KB:-

C:\HG612_Modem_Stats\Current_Stats\Current_Stats_20140710-1400-SCHEDULED

I suspect it was either absent or it contained very little data.



If your modem's firmware has been updated by BT & if you are still running very old versions of my programs, they will fail as the format of the data from the modem is incompatible with the older programs.



Hi everyone and thanks for your replies :)

Here are the versions I'm currently running:



I couldn't tell you versions I was running earlier (is there a way to find out?) but this issue was present before I tried updating it to see if that resolved the issue.

I've also restarted the OS (Windows Server 2008 R2) to alleviate any locked/hung processes and it didn't resolve the problem.

And yes all folders after "C:\HG612_Modem_Stats\Current_Stats\Current_Stats_20140707-2200-SCHEDULED" are empty and do not contain the Plink.log files.

Here is the entirety of the "CURRENT_ERROR.LOG_file_ERROR.TXT" file:

10/07/2014 18:48:42.24 - CURRENT-ISRUNNING-184842-135 - Start of [HG612_current_stats.exe] *** Version 3.0.0.0 - 22/06/14 ***
10/07/2014 18:48:42.54 - CURRENT-ISRUNNING-184842-135 - **** From IsRunningVB.exe, dslstatssampling.exe is *NOT* running
10/07/2014 18:48:43.97 - CURRENT-ISRUNNING-184842-135 - Starting to harvest the data for (xdslcmd info --stats). Status = 1
10/07/2014 18:48:44.68 - CURRENT-ISRUNNING-184842-135 - get_data() for (xdslcmd info --stats)    O.K. Status = 1, times in get_data() loop was 002
10/07/2014 18:48:44.90 - CURRENT-ISRUNNING-184842-135 - total_sleep_time = 0.000 seconds
10/07/2014 18:48:44.93 - CURRENT-ISRUNNING-184842-135 - Normal End of [HG612_current_stats.exe] - Status = 0,


10/07/2014 20:00:46.72 - CURRENT-ISRUNNING-200046-614 - Start of [HG612_current_stats.exe] *** Version 3.0.0.0 - 22/06/14 ***
10/07/2014 20:00:47.02 - CURRENT-ISRUNNING-200046-614 - **** From IsRunningVB.exe, dslstatssampling.exe is *NOT* running
10/07/2014 20:00:48.41 - CURRENT-ISRUNNING-200046-614 - Starting to harvest the data for (xdslcmd info --stats). Status = 1
10/07/2014 20:00:49.09 - CURRENT-ISRUNNING-200046-614 - get_data() for (xdslcmd info --stats)    O.K. Status = 1, times in get_data() loop was 002
10/07/2014 20:00:49.31 - CURRENT-ISRUNNING-200046-614 - total_sleep_time = 0.000 seconds
10/07/2014 20:00:49.34 - CURRENT-ISRUNNING-200046-614 - Normal End of [HG612_current_stats.exe] - Status = 0,


10/07/2014 22:00:03.74 - CURRENT-ISRUNNING-220003-607 - Start of [HG612_current_stats.exe] *** Version 3.0.0.0 - 22/06/14 ***
10/07/2014 22:00:04.13 - CURRENT-ISRUNNING-220003-607 - **** From IsRunningVB.exe, dslstatssampling.exe is *NOT* running
10/07/2014 22:00:04.21 - CURRENT-ISRUNNING-220003-607 - Parameter passed to [HG612_current_stats.exe] = SCHEDULED - i.e. ** AUTOMATICALLY ** initiated via HG612_stats.exe
10/07/2014 22:00:05.42 - CURRENT-ISRUNNING-220003-607 - Starting to harvest the data for (xdslcmd info --stats). Status = 1
10/07/2014 22:00:06.12 - CURRENT-ISRUNNING-220003-607 - get_data() for (xdslcmd info --stats)    O.K. Status = 1, times in get_data() loop was 002
10/07/2014 22:00:06.35 - CURRENT-ISRUNNING-220003-607 - total_sleep_time = 0.000 seconds
10/07/2014 22:00:06.38 - CURRENT-ISRUNNING-220003-607 - Normal End of [HG612_current_stats.exe] - Status = 0,


11/07/2014  0:54:08.94 - CURRENT-ISRUNNING-005408-824 - Start of [HG612_current_stats.exe] *** Version 3.0.0.0 - 22/06/14 ***
11/07/2014  0:54:09.26 - CURRENT-ISRUNNING-005408-824 - **** From IsRunningVB.exe, dslstatssampling.exe is *NOT* running
11/07/2014  0:54:09.41 - CURRENT-ISRUNNING-005408-824 - From IsRunningVB.exe, there are 1 instances of HG612_stats.exe running. Status = 1,
11/07/2014  0:54:18.12 - CURRENT-ISRUNNING-005408-824 - [HG612_current_stats.exe] waited 7.00 seconds for [HG612_stats.exe] to complete or time out. Status = 1,
11/07/2014  0:54:18.35 - CURRENT-ISRUNNING-005408-824 - [HG612_stats.exe] is still running, waiting another 6 seconds for it to complete or time out
11/07/2014  0:54:26.65 - CURRENT-ISRUNNING-005408-824 - [HG612_current_stats.exe] waited for a total of 13.00 seconds for [HG612_stats.exe] to complete or time out


Just before I checked that log again for this post I decided to click the "Run snapshot stats" again and it's currently frozen with this output (that last paragraph in the log above wasn't present till I clicked the button):

The local time is: 00:54:08.824
  **************************************************
  *                                                *
  *  Gathering Snapshot Statistics from the modem  *
  *                                                *
  **************************************************

 Couldn't determine Modem_type from ini file, defaulting to HG612
 Therefore command_prefix = xdslcmd


 *********************************
 *                               *
 *  Windows Version in use:-     *
 *                               *
 *  dwOSVersionInfoSize = 148    *
 *  dwMajorVersion      = 6      *
 *  dwMinorVersion      = 1      *
 *  dwBuildNumber       = 7601   *
 *  dwPlatformId        = 2      *
 *  szCSDVersion        = Service Pack 1       *
 *                               *
 *********************************

delay from ini file is 0

 ****************************************************
 *                                                  *
 *  OS is newer than XP, so ignoring delay setting  *
 *                                                  *
 ****************************************************


From IsRunningVB.exe, there are 1 instances of HG612_stats.exe running.
* seconds waited = 0.500000
* seconds waited = 1.000000
* seconds waited = 1.500000
* seconds waited = 2.000000
* seconds waited = 2.500000
* seconds waited = 3.000000
* seconds waited = 3.500000
* seconds waited = 4.000000
* seconds waited = 4.500000
* seconds waited = 5.000000
* seconds waited = 5.500000
* seconds waited = 6.000000
Waiting for 1 more second
* seconds = 6.500000
* seconds = 7.000000
 ************************************************************************
 * The modem is currently being accessed by HG612_stats.exe             *
 * Please wait a few seconds for it to complete                         *
 *                                                                      *
 * HG612_current_stats.exe should automatically resume in a few seconds *
 *                                                                      *
 ************************************************************************

* seconds = 7.500000
* seconds = 8.000000
* seconds = 8.500000
* seconds = 9.000000
* seconds = 9.500000
* seconds = 10.000000
* seconds = 10.500000
* seconds = 11.000000
* seconds = 11.500000
* seconds = 12.000000
Waiting for 1 more second
* seconds = 12.000000
* seconds = 12.500000
* seconds = 12.500000
* seconds = 13.000000
[HG612_current_stats.exe] waited for a total of 13.00 seconds for HG612_stats.ex
e to complete or time out
Temp File CURRENT-ISRUNNING-005408-824 was created

Creating log file Plink_20140711-0054.log


 # 1 of 16
 ## 2 of 16
 ### 3 of 16


Is that error in red of any use?

Here is an excerpt of the "ONGOING_ERROR.LOG" file:

11/07/2014 00:24:00.586 - [ IN HG612_stats.EXE ] - Start of 1 minute sampling - delayed by user setting of 0 seconds
11/07/2014 00:24:00.664 - dslstatssampling.exe was NOT running
11/07/2014 00:24:00.758 - HG612_current_stats.exe was NOT running
11/07/2014 00:24:00.758 - Temp File ONGOING-ISRUNNING-002400-101.TXT was created
11/07/2014 00:24:01.023 - malloc() O.K.
11/07/2014 00:24:01.023 - Initializing Winsock
11/07/2014 00:24:01.023 - WSAStartup() SUCCESSFUL!!!
11/07/2014 00:24:01.023 - Starting getaddrinfo()
11/07/2014 00:24:01.023 - getaddrinfo() O.K.
11/07/2014 00:24:01.023 - Starting socket()
11/07/2014 00:24:01.023 - socket() O.K.
11/07/2014 00:24:01.023 - Starting connect()
11/07/2014 00:24:01.023 - connect() O.K.
11/07/2014 00:24:02.461 - About to reply(xdslcmd info --stats)
11/07/2014 00:24:02.508 - reply(xdslcmd info --stats) O.K.
11/07/2014 00:24:03.133 - get_data() O.K.
11/07/2014 00:24:03.133 - ERROR!!! - Couldn't determine Modem in use, exiting
11/07/2014 00:24:03.226 - About to close(sockfd)
11/07/2014 00:24:03.226 - About to freeadddrinfo(res)
11/07/2014 00:24:03.226 - About to WSACleanup()
11/07/2014 00:24:03.304 - About to free(txbuf)
11/07/2014 00:24:03.367 - About to free(rxbuf)
11/07/2014 00:24:03.429 - Current  sync speeds are     DS 0 kbps      US 0 kbps, AS = 0
11/07/2014 00:24:03.429 - Previous sync speeds were    DS 0 kbps      US 0 kbps, AS = 0
11/07/2014 00:24:03.461 - ONGOING-ISRUNNING-002400-101.TXT DELETED
*********************************************************************************************************************
11/07/2014 00:24:03.492 - Scheduled snapshot logging is switched ON via the ini file
11/07/2014 00:24:03.492 - Current_Stats_Datum    = 06
11/07/2014 00:24:03.492 - Current_Stats_Interval = 8
11/07/2014 00:24:03.492 - (Time in Hours - Datum) Modulus Interval       i.e. (0 - 6) % 8 = -6
11/07/2014 00:24:03.492 - (Time in Minutes) = 24
11/07/2014 00:24:03.523 - Modulus & minutes *BOTH* have to be zero, so scheduled snapshot logging is NOT due yet
*********************************************************************************************************************
11/07/2014 00:24:03.554 - Scheduled Daily_Graphing is switched ON via the ini file
11/07/2014 00:24:03.554 - Daily_Graphing_hour    = 06
11/07/2014 00:24:03.554 - Daily_Graphing_minutes = 00
11/07/2014 00:24:03.554 - Current Time is Hours 00, Minutes 24
11/07/2014 00:24:03.570 - scheduled Daily_Graphing is NOT due yet
*********************************************************************************************************************
11/07/2014 00:24:03.617 - End of HG612_stats.exe program, EXIT error code = 0
11/07/2014 00:24:03.617 - End of HG612_stats.exe program, closing ERROR.LOG


And here is an excerpt of the "ONGOING_ERROR.LOG_file_ERROR.TXT" file:

10/07/2014 22:00:00.18 - ONGOING-ISRUNNING-220000-107.TXT - Start of [HG612_stats.exe] - **** Version 3.0.0.0 22/06/14 ****
10/07/2014 22:00:00.49 - ONGOING-ISRUNNING-220000-107.TXT - Immediately after ini_parse() - About to determine the OS version. ERROR.LOG status = 0,
10/07/2014 22:00:00.51 - ONGOING-ISRUNNING-220000-107.TXT - *** Windows version = [6.1.7601] ***
10/07/2014 22:00:00.54 - ONGOING-ISRUNNING-220000-107.TXT - In [HG612_stats.exe] - After obtaining the OS version. ERROR.LOG status = 0,
10/07/2014 22:00:00.59 - ONGOING-ISRUNNING-220000-107.TXT - ERROR.LOG successfully opened. Status = 1,
10/07/2014 22:00:00.70 - ONGOING-ISRUNNING-220000-107.TXT - **** From IsRunningVB.exe, dslstatssampling.exe is *NOT* running
10/07/2014 22:00:00.82 - ONGOING-ISRUNNING-220000-107.TXT - ONGOING-ISRUNNING-220000-107.TXT created. Status = 1,
10/07/2014 22:00:01.01 - ONGOING-ISRUNNING-220000-107.TXT - There are 1 instances of HG612_stats.exe running. Status = 1,
10/07/2014 22:00:01.04 - ONGOING-ISRUNNING-220000-107.TXT - Continuing as there are only 1 instances of HG612_stats.exe running **. Status = 1,
10/07/2014 22:00:01.85 - ONGOING-ISRUNNING-220000-107.TXT - expect("ATP>") O.K. Status = 1.
10/07/2014 22:00:02.48 - ONGOING-ISRUNNING-220000-107.TXT - Reaching this point means logging in to the modem was successful. Status = 1,
10/07/2014 22:00:02.54 - ONGOING-ISRUNNING-220000-107.TXT - reply(xdslcmd info --stats) O.K. Status = 1, return value = 0
10/07/2014 22:00:02.57 - ONGOING-ISRUNNING-220000-107.TXT - In get_data(#01). *** This was included in data received:- xdslcmd info --stats - (numbyes = 22, index = 22)
10/07/2014 22:00:03.17 - ONGOING-ISRUNNING-220000-107.TXT - In get_data(#02). *** This was included in data received:- xdslcmd info --stats - (numbyes = 2, index = 24)
10/07/2014 22:00:03.23 - ONGOING-ISRUNNING-220000-107.TXT - ERROR!!! - Couldn't determine Modem in use, exiting, ERROR.LOG status = 1
10/07/2014 22:00:03.26 - ONGOING-ISRUNNING-220000-107.TXT - Now in exit. Status = 1,
10/07/2014 22:00:03.29 - ONGOING-ISRUNNING-220000-107.TXT - *** WSACleanup has completed.
10/07/2014 22:00:03.34 - ONGOING-ISRUNNING-220000-107.TXT - *** About to free(txbuf).
10/07/2014 22:00:03.35 - ONGOING-ISRUNNING-220000-107.TXT - *** txbuf has been freed.
10/07/2014 22:00:03.40 - ONGOING-ISRUNNING-220000-107.TXT - *** About to free(rxbuf).
10/07/2014 22:00:03.42 - ONGOING-ISRUNNING-220000-107.TXT - *** rxbuf has been freed.
10/07/2014 22:00:03.46 - ONGOING-ISRUNNING-220000-107.TXT - *** Now checking for resyncs - There are 1 instances of HG612_stats.exe running.
10/07/2014 22:00:03.48 - ONGOING-ISRUNNING-220000-107.TXT - ONGOING-ISRUNNING-220000-107.TXT DELETED - Status = 1,
10/07/2014 22:00:03.52 - ONGOING-ISRUNNING-220000-107.TXT - *** Scheduled snapshot logging is switched ON.
10/07/2014 22:00:03.54 - ONGOING-ISRUNNING-220000-107.TXT - *** Scheduled snapshot logging IS due, running [HG612_current_stats.exe].
10/07/2014 22:00:03.62 - ONGOING-ISRUNNING-220000-107.TXT - *** Scheduled Daily graphing is switched ON.
10/07/2014 22:00:03.67 - ONGOING-ISRUNNING-220000-107.TXT - *** Scheduled Daily graphing is NOT due.
10/07/2014 22:00:03.74 - ONGOING-ISRUNNING-220000-107.TXT - End of [HG612_stats.exe], Closing ERROR.LOG. Status = 1,
10/07/2014 22:00:03.77 - ONGOING-ISRUNNING-220000-107.TXT - ERROR.LOG successfully closed. Status = 0,
10/07/2014 22:00:03.82 - ONGOING-ISRUNNING-220000-107.TXT - total_sleep_time = 1.100 seconds
10/07/2014 22:00:03.88 - ONGOING-ISRUNNING-220000-107.TXT - Normal End of [HG612_stats.exe]


I should note that in all the error logs I've posted above, there are no entries prior to the date/time of the last successful run.

So I'm noticing a pattern here in regards to it not being able to determine the modem.

As for the firmware version - I don't know of a way to capture this myself (presumably I can telnet in and run a command?) but I can say (if it's of any use!) that I flashed/unlocked the modem with the instructions and firmware from this site (http://huaweihg612hacking.wordpress.com/about/) no earlier than May of this year.

Is there any further information I can provide you with to help in a diagnosis?

And I'm extremely grateful for the technical help I've received so far :)
Logged

NewtronStar

  • Kitizen
  • ****
  • Posts: 4873
Re: Connection Stats Frozen/Not Updating
« Reply #6 on: July 11, 2014, 01:41:11 AM »


As for the firmware version - I don't know of a way to capture this myself (presumably I can telnet in and run a command?) but I can say (if it's of any use!) that I flashed/unlocked the modem with the instructions and firmware from this site (http://huaweihg612hacking.wordpress.com/about/) no earlier than May of this year.

Is there any further information I can provide you with to help in a diagnosis?

And I'm extremely grateful for the technical help I've received so far :)

You could log into telnet and type  "equipcmd swversion display"
and copy and past the info from the command prompt.

But we can see from the GUI you are on an older firmware A2pv6C030b.d22g you may need to update the firmware to A2pv6C038m.d24j

You can get the lastest firmware here -> http://www.kitz.co.uk/routers/hg612unlock.htm
« Last Edit: July 11, 2014, 01:57:02 AM by NewtronStar »
Logged

Bald_Eagle1

  • Helpful
  • Kitizen
  • *
  • Posts: 2721
Re: Connection Stats Frozen/Not Updating
« Reply #7 on: July 11, 2014, 07:38:59 AM »


Is there any further information I can provide you with to help in a diagnosis?

And I'm extremely grateful for the technical help I've received so far :)



I'll look into this when I get home from work tonight.

Logged

Bald_Eagle1

  • Helpful
  • Kitizen
  • *
  • Posts: 2721
Re: Connection Stats Frozen/Not Updating
« Reply #8 on: July 11, 2014, 12:29:10 PM »


Is there any further information I can provide you with to help in a diagnosis?



This bit concerns me:-

"Couldn't determine Modem_type from ini file, defaulting to HG612"


Could you post your entire ini file details for when I get home later on?


Logged

Ronski

  • Moderator
  • Kitizen
  • *
  • Posts: 4211
Re: Connection Stats Frozen/Not Updating
« Reply #9 on: July 11, 2014, 01:25:39 PM »

It would also be useful to post the modems.txt file which is located in a directory called Editor within the scripts folder.

Could you also post a screen shot of the modem settings tab as well please.

I notice in one of your posts there does seem to be a stuck instance of HG612_STATS.EXE

Logged
Formerly restrained by ECI and ali,  now surfing along at 390/36  ;D

Bald_Eagle1

  • Helpful
  • Kitizen
  • *
  • Posts: 2721
Re: Connection Stats Frozen/Not Updating
« Reply #10 on: July 11, 2014, 09:30:16 PM »

I think I MIGHT now have fixed that issue via Beta release of HG612_stats.exe v 3.0.0.2, now available via your GUI.

If not, it would be helpful if unconnected could post some of the other mentioned logs/files for us to look at.

Logged
 

anything