Kitz ADSL Broadband Information
adsl spacer  
Support this site
Home Broadband ISPs Tech Routers Wiki Forum
 
     
   Compare ISP   Rate your ISP
   Glossary   Glossary
 
Please login or register.

Login with username, password and session length
Advanced search  

News:

Author Topic: Contact BT Openreach Portal Staff  (Read 2831 times)

snadge

  • Kitizen
  • ****
  • Posts: 1394
Contact BT Openreach Portal Staff
« on: May 20, 2013, 09:55:33 PM »

I have a Portal Account on the BT Openreach website, it gives me access to some news and stuff that may not be published otherwise - they have strict security requiring password change every few weeks and password must upper & lower case letters, numbers and symbols - and must be unique and no iteration of previous passwords... I have somehow (probably with the help of Last Pass Browser Extension) got my last password change incorrect, I have reset the password and my account is "inactive" - when i click to activate it; it says that an admin has been informed to activate your account, but this was about 3-4 weeks ago and nothing is happening - I can not find any way of contacting someone about it.

can anyone help with this?

I have done it before but dont know how, I explained about my problem and they simply replied with "use forgot password link" .. that was it!!
Logged
BT900 <-> ONT <-> SmartHub 2.0
G/bit LAN to all devices <-> Speeds:
Excellent

burakkucat

  • Global Moderator
  • Senior Kitizen
  • *
  • Posts: 34344
  • Over the Rainbow Bridge
    • The ELRepo Project
Re: Contact BT Openreach Portal Staff
« Reply #1 on: May 20, 2013, 11:03:09 PM »

There appears to be a dedicated password helpdesk --
Logged
:cat:  100% Linux and, previously, Unix. Co-founder of the ELRepo Project.

Please consider making a donation to support the running of this site.

snadge

  • Kitizen
  • ****
  • Posts: 1394
Re: Contact BT Openreach Portal Staff
« Reply #2 on: May 21, 2013, 01:39:05 PM »

Hi bk,

Yeah I can use the password reminder but my account is inactive, so that doesn't work, I dunno how I contacted them last time..  I think there's something up with it as it's taking weeks for them to activate it..  So I would like to contact them through the proper channel

Sent from my Sony Xperia Miro on Tapatalk

Logged
BT900 <-> ONT <-> SmartHub 2.0
G/bit LAN to all devices <-> Speeds:
Excellent
 

anything