Kitz ADSL Broadband Information
adsl spacer  
Support this site
Home Broadband ISPs Tech Routers Wiki Forum
 
     
   Compare ISP   Rate your ISP
   Glossary   Glossary
 
Please login or register.

Login with username, password and session length
Advanced search  

News:

Author Topic: rs-ux and rs-w v0.71 released  (Read 2837 times)

roseway

  • Administrator
  • Senior Kitizen
  • *
  • Posts: 39518
  • Penguins CAN fly
    • DSLstats
rs-ux and rs-w v0.71 released
« on: August 26, 2012, 10:37:14 AM »

This is just a small bugfix release:
- The colours in the Connection speed graph which were interposed in v0.7 are now correct
- The blank Connection speed chart with connections over 10000 kbps now displays correctly

https://docs.google.com/folder/d/0BxbUtOYVZ_SCZ1BnY3RKYnN2b1U/edit

I've removed the v0.7 archives.
Logged
  Eric

broadstairs

  • Kitizen
  • ****
  • Posts: 3203
Re: rs-ux and rs-w v0.71 released
« Reply #1 on: August 26, 2012, 10:41:34 AM »

Just tried running it and I get a warning about a missing help file. Should add that after clicking on continue it started OK.

Stuart

PS. DSL Connection Uptime shows no information at the bottom of the screen, up and down speeds show fine.
PPS. Trivial but the screen title show 0.8 not 0.71 :-)
PPPS. Pause and resume works well and I can login via DMT while paused.
« Last Edit: August 26, 2012, 10:52:18 AM by broadstairs »
Logged
ISP:TalkTalk Connection:FTTC Cab:ECI Router:Netgear D6220

broadstairs

  • Kitizen
  • ****
  • Posts: 3203
Re: rs-ux and rs-w v0.71 released
« Reply #2 on: August 26, 2012, 10:56:27 AM »

The PS bit was getting silly  :blush: :blush:

One more suggestion, can you make the speed graph lines stand out more, maybe slightly thicker, as my upstream line is overlaying the dotted graph line and is almost invisible, since the SNR lines fluctuate they are easy to see.

Stuart
Logged
ISP:TalkTalk Connection:FTTC Cab:ECI Router:Netgear D6220

roseway

  • Administrator
  • Senior Kitizen
  • *
  • Posts: 39518
  • Penguins CAN fly
    • DSLstats
Re: rs-ux and rs-w v0.71 released
« Reply #3 on: August 26, 2012, 11:26:09 AM »

Stuart, I apologise. For the Linux 32-bit version I uploaded the uncompleted v0.8 by mistake. By all means carry on using it, but it does have some bugs and unfinished functions. I think you'll find that the resume feature only partly works, and it's still work in progress. I've uploaded the proper v0.71 now, and removed the improper one.
Logged
  Eric

burakkucat

  • Global Moderator
  • Senior Kitizen
  • *
  • Posts: 27732
  • Over the Rainbow Bridge
    • The ELRepo Project
Re: rs-ux and rs-w v0.71 released
« Reply #4 on: August 26, 2012, 06:23:53 PM »

Version 0.71, 64-bit downloaded and is now being tested.

The first few data points have already been plotted and I can confirm that the "colour of the curves" issue for the Connection speed graph is now resolved.
Logged
:cat:  100% Linux and, previously, Unix. Co-founder of the ELRepo Project.

Please consider making a donation to support the running of this site.

roseway

  • Administrator
  • Senior Kitizen
  • *
  • Posts: 39518
  • Penguins CAN fly
    • DSLstats
Re: rs-ux and rs-w v0.71 released
« Reply #5 on: August 26, 2012, 06:43:47 PM »

Thanks Mr Cat. :)
Logged
  Eric

burakkucat

  • Global Moderator
  • Senior Kitizen
  • *
  • Posts: 27732
  • Over the Rainbow Bridge
    • The ELRepo Project
Re: rs-ux and rs-w v0.71 released
« Reply #6 on: August 26, 2012, 08:44:47 PM »

My first report.

Upon selecting the Telnet data tab and then taking either the Bitloading or the SNR tabs (screenshots attached, below) I see that there is a minor alignment issue with the earlier data. It looks as if the numerical data is left-justified within the allocated field-width. Could right-justification be tried, please?

I shall be "out for the day", tomorrow (Monday) and so will perform further tests on version 0.71 from Tuesday onwards.
Logged
:cat:  100% Linux and, previously, Unix. Co-founder of the ELRepo Project.

Please consider making a donation to support the running of this site.

Bald_Eagle1

  • Helpful
  • Kitizen
  • *
  • Posts: 2721
Re: rs-ux and rs-w v0.71 released
« Reply #7 on: August 26, 2012, 09:35:16 PM »


The only Windows version currently available for downoad via the link appears to be older version 0.5  ???

Logged

roseway

  • Administrator
  • Senior Kitizen
  • *
  • Posts: 39518
  • Penguins CAN fly
    • DSLstats
Re: rs-ux and rs-w v0.71 released
« Reply #8 on: August 26, 2012, 10:02:16 PM »

The only Windows version currently available for downoad via the link appears to be older version 0.5  ???

Version 0.71 is there now. I don't know where it went - I'm sure I uploaded it earlier. ???
Logged
  Eric

roseway

  • Administrator
  • Senior Kitizen
  • *
  • Posts: 39518
  • Penguins CAN fly
    • DSLstats
Re: rs-ux and rs-w v0.71 released
« Reply #9 on: August 26, 2012, 10:19:00 PM »

Upon selecting the Telnet data tab and then taking either the Bitloading or the SNR tabs (screenshots attached, below) I see that there is a minor alignment issue with the earlier data. It looks as if the numerical data is left-justified within the allocated field-width. Could right-justification be tried, please?

I don't think it's a matter of justification. I think it's tab settings. All I do is load the raw telnet data into the memo control which displays it, and that's how it comes out. I'll see what I can do.
Logged
  Eric

Bald_Eagle1

  • Helpful
  • Kitizen
  • *
  • Posts: 2721
Re: rs-ux and rs-w v0.71 released
« Reply #10 on: August 26, 2012, 10:28:10 PM »

Bitloading & SNR look to be correctly formatted on my Windows version, but pbParams data is slightly off here & there.

I wonder if a fixed width font would fix that?

Logged

roseway

  • Administrator
  • Senior Kitizen
  • *
  • Posts: 39518
  • Penguins CAN fly
    • DSLstats
Re: rs-ux and rs-w v0.71 released
« Reply #11 on: August 26, 2012, 11:18:16 PM »

Quote
I wonder if a fixed width font would fix that?

It will certainly help with tab alignment, although I think your pbParams example above shows that the tab value isn't right for the text shown. I'll do some character counting and try to optimise it.
Logged
  Eric