Kitz Forum

Computer Software => Windows => Topic started by: scottiesmum on November 04, 2008, 11:43:24 AM

Title: Strange message when closing down !
Post by: scottiesmum on November 04, 2008, 11:43:24 AM
This has happened for about a fortnight !!! I know that's a while ago, but I didn't give it much thought .. however NOW it's starting to aggravate me !

When I turn off the machine I get this message....CLICK TURN OFF TO INSTALL IMPORTANT UPDATES AND TURN OFF YOUR COMPUTER. CLICK HERE TO TURN OFF WITHOUT INSTALLING UPDATES.

I have ALL the Windows updates, I've checked and double checked ..so I am baffled .... is there something I should do ?

Thank you in advance....
Title: Re: Strange message when closing down !
Post by: tuftedduck on November 04, 2008, 12:27:06 PM
It would appear that you have your PC set for automatic download of MS patches, but with the option to install them manually rather than auto install.
The message seems to indicate that that one or more patches has not downloaded properly.

If you go back to the MS Update site through IE>tools>Windows Update then look at the "review update history" page, it may highlight something that has not come down properly.


ps that roseway keeps moving you around, doesn't he ?  ;D
Title: Re: Strange message when closing down !
Post by: scottiesmum on November 04, 2008, 03:22:16 PM
Thanks for that TD   ....  I've checked the download history as far back as it goes  19th March 2008 and every one has a green tick and is marked update successful .... I actually have it set for automatic update and download, I know this is not popular with some people, but I've always done it and this is the first 'obvious' blip   :'(  strange isn't it  ....

(anyway, now that I've found my way back to the NC  ...  I think secretly Eric wanted it for himself because it's so nice, he's tried to confuse me  ;D )
Title: Re: Strange message when closing down !
Post by: roseway on November 04, 2008, 03:41:09 PM
Roseway relaxing by himself in the French NC

(http://www.dreamstime.com/man-relaxing-on-a-boat-thumb2735769.jpg)
Title: Re: Strange message when closing down !
Post by: scottiesmum on November 04, 2008, 03:59:54 PM
 :lol:

and he's doesn't look very bothered about my problem  :-X
Title: Re: Strange message when closing down !
Post by: tuftedduck on November 04, 2008, 04:31:21 PM
He's a moderator and believes in the maxim about rank having it's privileges.  :D

One or more of your updates has been corrupted somewhere between the update server and you......and has not installed properly.
Can you go back to the start of the problem and identify which updates occurred at that time ?
If you can, can you uninstal them and try a re-download/instal
Title: Re: Strange message when closing down !
Post by: scottiesmum on November 04, 2008, 04:38:29 PM
 :'( :'(   I honestly can't remember when I first noticed the message TD  .....  is there any way to check if a download is corrupted or not ??  (will it have an oversized navy blue overcoat on for example  ;D )  .........  oooooooooooo it's at times like this I wish I knew what I was doing  ::)
Title: Re: Strange message when closing down !
Post by: Floydoid on November 04, 2008, 04:39:46 PM
:'( :'(   I honestly can't remember when I first noticed the message TD  .....  is there any way to check if a download is corrupted or not ??  (will it have an oversized navy blue overcoat on for example  ;D )  .........  oooooooooooo it's at times like this I wish I knew what I was doing  ::)

Kate, have you tried going to the MS updates page and running a manual update?
Title: Re: Strange message when closing down !
Post by: scottiesmum on November 04, 2008, 04:42:57 PM
Hello Floydy ...   I did that this morning, it tells me I have my updates set for auto ... however,  there was an update available which I did manually.     I've been having a little look around and found this advice  ....  should I follow it  ??

"If you get a corrupted or incomplete download from Windows Update, it can indeed cause big trouble. Most problems with automatic update downloads can be solved using this simple routine. From the Start menu's Run dialog, launch Services.msc. In the resulting list find the item named Automatic Updates. Double-click it to open its Properties and click the Stop button, then leave the Properties window open.

Launch Windows Explorer, navigate to C:\Windows, and find the folder named SoftwareDistribution. Rename this folder SoftwareDistribution.old. Now go back to that Properties window and click the Start button to restart the Automatic Updates service. That should clear up the problem. At the next automatic update your system will receive the necessary files, and this time, we can hope, they'll be complete and uncorrupted."

 :-\
Title: Re: Strange message when closing down !
Post by: tuftedduck on November 04, 2008, 04:45:24 PM
Before doing that, have a look in your update log............it may give you an idea as to chronological events.

Click Start, and then click Run.
   In the Open box, type %windir%\windowsupdate.log, and then click OK.
Title: Re: Strange message when closing down !
Post by: Floydoid on November 04, 2008, 04:57:31 PM
It sounds like good advice Kate. :)
Title: Re: Strange message when closing down !
Post by: oldfogy on November 04, 2008, 05:01:20 PM

..CLICK TURN OFF TO INSTALL IMPORTANT UPDATES AND TURN OFF YOUR COMPUTER.

I have ALL the Windows updates, I've checked and double checked ..so I am baffled .... is there something I should do ?

The problem is that the update has already been downloaded to your PC and is now waiting for you to install it.
You should see a "Yellow Shield" next to the clock (notification area) just "right click" it and select install etc.

The best thing to do is just except the install notice, then after the install and probably PC re-start change the auto update to whatever you want.
Then the message will not appear again.

Although I believe you can remove the update but, it's best to just install it.

Because this update has already been downloaded, MS update probably does not recognise it as a new update.

Warning - while you were typing a new reply has been posted. You may wish to review your post
Title: Re: Strange message when closing down !
Post by: scottiesmum on November 04, 2008, 05:06:50 PM
I tried your advice TD  but %windir%\windowsupdate.log,  gave me the message that Windows could find this  ... then I tried it without the % bits  ::)  ...same message, then without the comma after log ... still same message   ..... 

OF  .. thank you for that .... there was a yellow shield this morning and I clicked on to install it and it said it had installed successfully...  I was surprised after this that I still get the message at turn off  !!   I'm going to check the list of updates and will post a screen shot  .... merci  encore !
Title: Re: Strange message when closing down !
Post by: oldfogy on November 04, 2008, 05:07:57 PM
Quote

Click Start, and then click Run.
   In the Open box, type %windir%\windowsupdate.log, and then click OK.
Kate you do not need to remove the % bits.

Yes I know you removed your post (don't know how) but ..........
Either that or your last post has dissapeared..


Warning - while you were typing a new reply has been posted. You may wish to review your post.

************
edit
In which case just select the install option from the shutdown screen when it appears.
Title: Re: Strange message when closing down !
Post by: scottiesmum on November 04, 2008, 05:27:58 PM
I'm getting so confused now  ..    sorry ...    OK  I've tried the Run advice from TD ..  I've copy and pasted it again and I still get  th Windows can't find  .. message..     another strange thing .. I have the 'show updates' on the Add/Remove programme facility ... BUT when I look at the updates that have supposedly been installed ( according to the Windows update page) they don't correspond  !!    for example 

(http://img.villagephotos.com/p/2005-5/1013475/ScreenHunter_06Nov.0418.12.gif) 

 none of these are shown as updates on the Add/Remove list ...   is it just that not all updates are included on the Add Remove section  ??   
Title: Re: Strange message when closing down !
Post by: scottiesmum on November 04, 2008, 05:36:35 PM
I've just looked at something on the list I've posted ....   I KNOW I installed SP3 on my machine ..... all those updates refer to SP2  ??    :cry2: :swoon:

am I in a bigger mess than I thought ??  :'(
Title: Re: Strange message when closing down !
Post by: oldfogy on November 04, 2008, 05:41:56 PM
Did you remember to click the box to "Show Updates" in Add or Remove just above the top of the list?
Although I think you are possibly getting carried away with trying to find it instead of just letting it install.

Have you tried just selecting the install option when closing down ?
Title: Re: Strange message when closing down !
Post by: scottiesmum on November 04, 2008, 05:47:23 PM
OF ..you are so patient !     Yes, I have chosen the install and close down option, and it installed and closed down ... but following that I still have the same message each time I turn off the machine.    AND  ....  I ALWAYS click install when the yellow shield appears.

As everything else seems to be OK ...and MS assure me I have all the updates ....  don't bother yourself any more  ... !! THANK YOU so much ...   I'll will have to be really rude now and leave all this, because we have people arriving for aperitifs  !!!!  so I'd better get pouring  ...   most grateful ...just hope it "goes away"   :no:
Title: Re: Strange message when closing down !
Post by: tuftedduck on November 04, 2008, 05:48:38 PM
>>> I'm getting so confused now <<< Could you put Scotty on the line please.  :D

Some updates go right into the core of the system and cannot be uninstalled as individual items...........presumably then they do not appear in the add/remove list.

I suggest you follow the advice from OF , then look again in a fresh mind tomorrow if the message has appeared at close down tonight.  :)
Title: Re: Strange message when closing down !
Post by: oldfogy on November 04, 2008, 06:01:11 PM

1.  ... but following that I still have the same message each time I turn off the machine.

2. AND  ....  I ALWAYS click install when the yellow shield appears.


1. Some updates have to be installed individually so it may appear 2 or 3 times (although this is not very often)
2. Don't bother with the yellow shield, doubtfully though but it may be confusing matters.

Mines a G&T no ice just a slice of lime.  :drink:
Title: Re: Strange message when closing down !
Post by: scottiesmum on November 04, 2008, 10:47:00 PM
I'm back  !!   but not going to do anything further on this tonight ... taking TD's advice and looking at it with 'new eyes' tomorrow.   I can't cope with this AND the US election !   :no:

Thank you OF for all the information ...and hope you enjoyed the G&T   ;D

Bonne Nuit ! 
Title: Re: Strange message when closing down !
Post by: roseway on November 04, 2008, 11:07:01 PM
>> Bonne Nuit !

Was that another strange message when closing down? :lol:
Title: Re: Strange message when closing down !
Post by: scottiesmum on November 05, 2008, 09:06:21 AM


 :P ;D  Eric  ...   you are just looking fora permanent place in the NC  !  :whip:


This morning I had the yellow shield again   ... the download in this instance was  MS  XML Core Services 4.0    Service Pack 2  KB936181  Update 1 of 1 ....  so I clicked install...     I've checked in the Add/Remove section and this new update is listed.  I have not yet turned off  again to see if infernal message is still there  ..  it was when I switched off last night  ::)
Title: Re: Strange message when closing down !
Post by: tuftedduck on November 05, 2008, 09:11:30 AM
Bonjour.....I hope you did not toss and turn all last night thinking about this.

One wee thought, if the b****** message is still there next time you turn off/on try the install option again but this time, immediately before clciking the install button, switch off your AV and firewall progs, see if that helps. (Don't forget to turn on again next restart.....as if you would  ;) )
Title: Re: Strange message when closing down !
Post by: Floydoid on November 05, 2008, 09:48:15 AM
Kate that seems like it's quite an old update.... if push comes to shove, you could download the setup file and install it manually.

http://www.microsoft.com/downloads/details.aspx?FamilyID=021e12f5-cb46-43df-a2b8-185639ba2807&DisplayLang=en
Title: Re: Strange message when closing down !
Post by: mr_chris on November 05, 2008, 10:55:38 PM
Kate.. just a quick question, perhaps a stupid one actually... but have you actually clicked the "Shut down and Install updates" button, rather than the "Turn off without installing" link? I'm thinking that should clear whatever it thinks it needs to install...

Or am I over-simplifying things? ;)
Title: Re: Strange message when closing down !
Post by: scottiesmum on November 06, 2008, 08:31:00 AM
Mr.Chris,  yes I've done both, several times   :'(     I tried TD's suggestion   (thank you)  of turning off the AV and Firewall before "shutting down and install" option, but still had same message on closing   :shrug2: :shrug2:   I'm now going to look at Floydy's link ( thank you) to see if I can work out what he means  ;D 

I'll keep you all posted  ..........that means I'll be back to nag you all again  ;D


Title: Re: Strange message when closing down !
Post by: Floydoid on November 06, 2008, 10:23:32 AM
I'm now going to look at Floydy's link ( thank you) to see if I can work out what he means  ;D 

... many have tried but few have succeeded.  ???

Actually all you have to do is click the download link on that page for the file to arrive in your download folder (or wherever you d/l your stuff to).  Once it's done, double click on the file and it will install itself.  It may request you re-boot to complete the installation.
Title: Re: Strange message when closing down !
Post by: scottiesmum on November 06, 2008, 12:19:57 PM
I'm sure you must all be bored with this ...  :-\ but I think I am slowly going mad ....  :silly:

The Yellow install shield is permanently on the task bar  !!   I press install and it twiddles and finishes and then re-appears.

The offending update   KB936181  appears on my  "download history page on the Windows Update site" no less than 17 times as being successfully installed  !!

When I go to check for downloads ....  I'm told I'm set for automatic downloads, SO,  I switched that off, went back to check and it said I had one recommended download   ..... KB936181    :crazy:   I let it install yet again !

The yellow shield is still there   .....  I'm getting quite paranoid about it now :o  .....  and the message is still there when I go to Turn Off.   

I've looked at more FAQ's, Troubleshooting and other pages than I can list  and I'm still lost as to what to do.

I DID find the log as per TD's suggestion (the \ and / were the wrong way around hence original problem finding it)  and I have found this at today's date :-


2008-11-06   12:48:46:812   1100   da8   Report   REPORT EVENT: {3BDA642A-E836-4FC0-9E37-4F0028FF9F86}   2008-11-06 12:48:41:812+0100   1   183   101   {2B0B2515-192D-470A-9745-4A3FB7C02030}   105   0   MicrosoftUpdate   Success   Content Install   Installation Successful: Windows successfully installed the following update: Security Update for Microsoft XML Core Services 4.0 Service Pack 2 (KB936181)

 :-X :'( :no:  aaaaaaaaaaaaaaaaaaaaaaaaaarrrrrrrrrrrrrrrrrrrrrrrrgh  !      Can I  safely  delete this  darn update and start again ??   
 If so, how  ?  .....A BIG Thank you to all who are persevering  :)


Since posting this  I have turned off computer ... message STILL there  .... when I switch on yellow shield is NOT showing...  I click on Turn Off and message is NOT there  ...THEN  I connect to the internet ... Yellow shield appears,  back to Turn Off message is there again  ?? 

PS.  Would it help (anyone) if I posted an excerpt from the Log  ??

I think I've scared everyone off  !!   ;D     I've been looking at the Log and also at an MS page that explains how to look at the log.  Put in the KB936181 in Find and it came up with this  ....2008-11-06   13:28:13:953   1116   df0   Report   REPORT EVENT: {E24FCB5D-7C2A-44A2-AF85-3683D5FC8A97}   2008-11-06 13:28:07:968+0100   1   188   102   {00000000-0000-0000-0000-000000000000}   0   0   Automatic Updates   Success   Content Install   Installation Ready: The following updates are downloaded and ready for installation. This computer is currently scheduled to install these updates on Friday, November 07, 2008 at 10:00 AM: - Security Update for Microsoft XML Core Services 4.0 Service Pack 2 (KB936181)

I have the Automatic Updater set for checking every day at 10 am  ...  SO  I have just changed that to 14.00 to see if the installation takes place any time now ??  I'm not sure if this will cure it - will be back soon ... my only query here is why does it not know it's already installed ???
Title: Re: Strange message when closing down !
Post by: roseway on November 06, 2008, 01:11:26 PM
Not being a Windows person I may be speaking out of turn, but can you uninstall the update and delete the downloaded files, then start again?
Title: Re: Strange message when closing down !
Post by: scottiesmum on November 06, 2008, 01:18:19 PM
EUREKA   !!!!!!!!!!!!!!!!!!!!!!!!!!!!


I've done it   !!!     actually Eric,   I did what you have posted, but before you posted it   (honestly )       I only discovered today the problem update .... and I'm always extremely wary about deleting things that might be necessary ... but it was really getting on my nerves   (and everyone else's  ;D ) so I went for it   ...and it's done  !!!   Thank you for your input.

Many thanks to all , sorry if you've trawled through my long post   .............   ooooooh I'm so    :clap: :clap2: :love2: ^-^ :dance: :dance:
Title: Re: Strange message when closing down !
Post by: UncleUB on November 06, 2008, 01:21:46 PM
(http://dl3.glitter-graphics.net/pub/1527/1527413i733yi0smv.gif) (http://www.glitter-graphics.com)


PS,looks like a young lady for TD.  :lol:
Title: Re: Strange message when closing down !
Post by: roseway on November 06, 2008, 01:27:31 PM
:lol:

Well done Kate.
Title: Re: Strange message when closing down !
Post by: tuftedduck on November 06, 2008, 01:38:48 PM
 :thumbs: :clap: :clap2: :dance: :congrats: :drink: :sun: :sun:

Wooo hooo.

Send 'er round, unkyUb  :lol:


When I read what KB was causing the problem, I was going to post this, but I won't bother now  :D

•   Security update 936181 for Microsoft XML Core Services (MSXML) 4.0, for MSXML 4.0 Service Pack 1 (SP1) and for MSXML 4.0 Service Pack 2 (SP2) does not support the complete removal of MSXML 4.0. This situation occurs because this version of MSXML is installed in side-by-side mode. To work around this issue, follow these steps:   1.   Remove security update 936181 by using the Add or Remove Programs item in Control Panel.
2.   Delete the Msxml4.dll file from the %SystemRoot%\System32 folder.
3.   Repair the previous installation of MSXML 4.0 by using the Add or Remove Programs item in Control Panel.

The earlier versions of the Msxml4.dll file and of the Msxml4r.dll file are restored to the side-by-side folder and to the %SystemRoot%\System32 folder.
•   You may receive the following error message when you install security update 936181 from Windows Update:
Could not register type library for file c:\Windows\system32\msxml4.dll. Contact your support personnel.
When this error occurs, you may also notice information that resembles the following in the log file:
Error 1911. Could not register type library for file c:\Windows\system32\msxml4.dll. Contact your support personnel.
MSI (s) (20:18) [17:52:31:612]: Product: MSXML 4.0 SP2 (KB936181) -- Error 1911. Could not register type library for file c:\Windows\system32\msxml4.dll. Contact your support personnel.
=== Logging stopped: 11/10/2006 17:53:07 ===
MSI (c) (34:20) [17:53:07:252]: Note: 1: 1708
MSI (c) (34:20) [17:53:07:260]: Product: MSXML 4.0 SP2 (KB936181) -- Installation failed.
MSI (c) (34:20) [17:53:07:267]: Windows Installer installed the product. Product Name: MSXML 4.0 SP2 (KB936181). Product Version: 4.20.9839.0. Product Language: 1033. Installation success or error status: 1603.
MSI (c) (34:20) [17:53:07:313]: Grabbed execution mutex.
MSI (c) (34:20) [17:53:07:319]: Cleaning up uninstalled install packages, if any exist MSI (c) (34:20) [17:53:07:331]: MainEngineThread is returning 1603
=== Verbose logging stopped: 11/10/2006 17:53:07 ===
To work around this problem, manually install the security update from the Microsoft Download Center, and then click Ignore when the error message is displayed. To confirm that the installation was successful, verify that the Msxml4.dll file in %systemroot%\System32 is version 4.20.9848.0.
Title: Re: Strange message when closing down !
Post by: scottiesmum on November 06, 2008, 01:46:04 PM
@ Unc    :lol: :lol:


Thanks for that TD    :lol:


PS  on top of all this  the  :sun: is back   or should that be (http://img.villagephotos.com/p/2005-5/1013475/sunny01.gif)   :lol: :lol:

I've gone quite hysterical  ...   quackers in fact !!!     8)
Title: Re: Strange message when closing down !
Post by: tuftedduck on November 06, 2008, 01:51:21 PM
Calm down, woman, and have a bottle or two of home grown to celebrate. :D


(guys, she will be shutting down that b****** machine  ten times a day now to enjoy the freedom......we'll never hear the end of it )  :lol:
Title: Re: Strange message when closing down !
Post by: UncleUB on November 06, 2008, 01:51:54 PM
I new she had been at the   (http://dl3.glitter-graphics.net/pub/1462/1462393dkunpf0wdc.jpg) (http://www.glitter-graphics.com)    :lol:


Last time I got that excited is when I we Kate installed Firefox.  :lol:
Title: Re: Strange message when closing down !
Post by: Floydoid on November 06, 2008, 02:21:40 PM
Glad you got it sorted Kate. :)
Title: Re: Strange message when closing down !
Post by: scottiesmum on November 06, 2008, 02:28:17 PM
Thank you Floydy   .....



Unc and TD  ...  As a special "thank you"  to you  I've arranged a new NC to be built ...... .....  in the Outer Hebrides  :angel:
Title: Re: Strange message when closing down !
Post by: oldfogy on November 06, 2008, 05:12:02 PM

Can I  safely  delete this  darn update and start again ??   
 If so, how  ? 

Yes you can, just use "Add or remove programs"
If you have more than one for the same update, just remove them all one-by-one.
Although it will try and download again the next time you update.

Are you still getting the notice from the shutdown button?

Also which AV and Firewall are you using.
(Just wondering if it's just the (shield) notification that windows does not recognise either you AV or firewall)
(Which can be disabled in windows, Control panel > "Security Center")
Just out of curiosity, take a look there and see if it's showing anything as not being protected.
Title: Re: Strange message when closing down !
Post by: scottiesmum on November 06, 2008, 05:20:07 PM
OF .....  All is well  ....see my Eureke above  .....  I removed the offending update, then went onto the Updates site and let it do it again, it all seems FINE now.    I've learned some quite interesting things whilst doing this  ..... thanks for your interest and help. 
Title: Re: Strange message when closing down !
Post by: oldfogy on November 06, 2008, 05:46:05 PM
Sorry Kate.
We are now on page 3, I must have somehow skipped past all of the posts above on this page so did not see it.
 :-[

As all of the Hallelujah's and Praises have been said, please add mine to them.