Kitz ADSL Broadband Information
adsl spacer  
Support this site
Home Broadband ISPs Tech Routers Wiki Forum
 
     
   Compare ISP   Rate your ISP
 
Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: 1 [2]

Author Topic: Channel 5 and their Demand5 site on Linux  (Read 3599 times)

Mick

  • Reg Member
  • ***
  • Posts: 292
Re: Channel 5 and their Demand5 site on Linux
« Reply #15 on: January 10, 2016, 10:56:12 PM »

Hmm ... I tried changing the user agent on FF to that of iPad and it is still asking me to go get "Adobe Flash Player version 15.0.0 or greater".  :-(
Logged
Regards,
Mick

currytop

  • Reg Member
  • ***
  • Posts: 113
Re: Channel 5 and their Demand5 site on Linux
« Reply #16 on: January 10, 2016, 11:01:38 PM »

What User Agent string do you get reported when you go here using your iPad? Is that the string you use in FF?
Logged

Weaver

  • Kitizen
  • ****
  • Posts: 4004
  • Retd sw dev; A&A; 3 7km ADSL2; IPv6; Firebrick
Re: Channel 5 and their Demand5 site on Linux
« Reply #17 on: January 10, 2016, 11:07:31 PM »

It's truly ironic that they named it "Demand 5".

How ridiculous that the cretins who designed it should leave users having to consider desperate measures such as fiddling with user-agent strings. Shame on Channel 5.
Logged

currytop

  • Reg Member
  • ***
  • Posts: 113
Re: Channel 5 and their Demand5 site on Linux
« Reply #18 on: January 10, 2016, 11:45:41 PM »

I've just tried again with a current iPad useragent string and it fails. What I've just remembered though is that this kludge doesn't change the user agent string reported in javascript. That requires a different fix. I'll look through my old notes. But later in the week.
Logged
Pages: 1 [2]
 

anything